m.fool.com doesn't display correctly in Gaia browser

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: efrat, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff][country-us] [sitewait], URL)

Attachments

(1 attachment)

48.42 KB, image/jpeg
Details
(Reporter)

Description

6 years ago
Created attachment 766442 [details]
fool.jpg

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce:

Browsed to "http://m.fool.com/" from Gaia browser

Tested on Firefox OS simulator
OS version 1.1.0.0-prerelease
Build Identifier 20130522133646

User Agent String is:
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36


Actual results:

On a device - browser is stuck for a few seconds and then crashes, followed by this error message:

XML Parsing Error: XML or text declaration not at start of entity
Location: http://m.fool.com/
Line Number 2, Column 2:
	<?xml version="1.0" encoding="UTF-8" ?>
(see attachment)

Model: ZTE Open
OS version: 1.0.1.0-prerelease
Firmware: V1.01.00.01.019.117
Platform:18.0
Build identifier:20130528094315


Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly on Firefox for Android and Chrome for Android
This bug should feel familiar to ex-Opera employees.

Most telling parts in the response: 

Content-Type	application/xhtml+xml; charset=utf-8
Server	Microsoft-IIS/7.5

...

<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"> 
	<head> 
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0;" /> 
		<meta http-equiv="content-type" content="text/html; charset=utf-8" /> 
		<title>Home | The Motley Fool</title> 
		<!-- Global Stylesheets -->
		<style type="text/css" media="screen">@import "/common/css/Mobile/Common.css";</style>  
		<!-- Global JavaScript --> 
		<script type="text/javascript" charset="utf-8" src="/common/js/Mobile/Basic.js" /> 

The server doesn't recognize the UA and so it sends it to a generic WAP site, but is sending malformed XHTML/XML hence the draconian XML error.

MobileSiteFeedback@fool.com
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [serversniff][country-us][contactready]
(Assignee)

Comment 2

5 years ago
Contacted with the email.
Assignee: nobody → kdubost
Whiteboard: [serversniff][country-us][contactready] → [serversniff][country-us][contactready] [sitewait]
The version that iOS and stock Android get sent contains http://j.foolcdn.com/common/js/Mobile/webkit.min.js?v=78971trans. As far as I can tell, there isn't any webkit specific code in there that would break for Firefox OS (it just contains jQuery, Sizzle, and some app-specific code using regular jQuery API methods).
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Duplicate of this bug: 867258
(Assignee)

Comment 5

5 years ago
hmm there is a pretty sophisticated UA sniffing going on. Very precise and failing…

# User-Agent: Mobile, Accept: */*

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.fool.com
User-Agent:  Mobile



HTTP/1.1 200 OK
Cache-Control: private
Content-Encoding: gzip
Content-Type: text/html; charset=utf-8
Date: Wed, 13 Nov 2013 18:46:29 GMT
P3P: policyref="http://www.fool.com/w3c/p3p.xml", CP="IDC DSP COR CUR ADMa DEVa TAIa CONo HISa TELo OUR PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA PRE LOC IND"
Server: Microsoft-IIS/7.5
Set-Cookie: Visit=visit=36fc0b1a-28ad-4924-ae85-e18ea48e41d2; domain=.fool.com; expires=Wed, 13-Nov-2013 19:16:28 GMT; path=/
Set-Cookie: Visitor=visitor=004e8937-5232-4887-8693-8f13d5e67f7e&uid=&username=&visits=1&version=3; domain=.fool.com; expires=Mon, 13-Nov-2023 05:00:00 GMT; path=/
Set-Cookie: Sookie=source=NoSource&ybls=0; domain=.fool.com; path=/
Set-Cookie: Wookie=; domain=.fool.com; expires=Thu, 14-Nov-2013 18:46:28 GMT; path=/
Set-Cookie: Tookie=Tookie=&T=89008064974884449580124950422255; domain=.fool.com; expires=Sat, 11-Nov-2023 18:46:29 GMT; path=/
Set-Cookie: v1st=81E3AD44CBBF2227; path=/; expires=Wed, 19 Feb 2020 14:28:00 GMT; domain=.fool.com
Set-Cookie: incap_ses_120_92455=EfgTY9EZzgq4sBf801OqAQTJg1IAAAAAdTC+E+ffODLF/rvR1jdSKA==; path=/; Domain=.fool.com
Set-Cookie: visid_incap_92455=jgYZ4VOrQZO8SpxlAmLs/ATJg1IAAAAAQUIPAAAAAADAjU/z6pBl5MXQA9O84Vl5; expires=Fri, 13 Nov 2015 10:12:50 GMT; path=/; Domain=.fool.com
Transfer-Encoding: chunked
X-AspNetMvc-Version: 2.0
X-CDN: Incapsula
X-Iinfo: 5-5661039-5661040 NNNY CT(29 -1 0) RT(1384368387523 0) q(0 0 0 -1) r(12 12) U2
X-Powered-By: web17

<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
	<html xmlns="http://www.w3.org/1999/xhtml"> 

	<head>
		<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0;"/>



# Firefox OS… Same parameters except the User Agent changes.

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: m.fool.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0



HTTP/1.1 200 OK
Cache-Control: no-cache
Connection: close
Content-Length: 385
Content-Type: text/html
Set-Cookie: incap_ses_120_92455=+7kZYuSYS16EFhj801OqAU/Jg1IAAAAAeZfRKsTFmKjqUc70ulsjlg==; path=/; Domain=.fool.com
Set-Cookie: visid_incap_92455=AzIFwt+/QX6ESumL4tlMjE/Jg1IAAAAAQUIPAAAAAABIhqTZxMpBPJZc+THTerWq; expires=Fri, 13 Nov 2015 10:12:50 GMT; path=/; Domain=.fool.com
X-Iinfo: 5-5679952-0 0NNY RT(1384368463947 0) q(0 -1 -1 -1) r(0 -1) B12(4,315,0) U2

<html><head><META NAME="ROBOTS" CONTENT="NOINDEX, NOFOLLOW"></head><iframe src="/_Incapsula_Resource?CWUDNSAI=9_46FF311A&incident_id=120000510011236743-45662425851626293&edet=12&cinfo=42cfd066c753860404000000" frameborder=0 width="100%" height="100%" marginheight="0px" marginwidth="0px">Request unsuccessful. Incapsula incident ID: 120000510011236743-45662425851626293</iframe></html>


Now let's try to modify the Accept header to text/html.

GET / HTTP/1.1
Accept: text/html
Accept-Encoding: gzip, deflate, compress
Host: m.fool.com
User-Agent:  Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

We get the same result with the iframe. OK. so let's try to add an accept language header. On my ZTE Open, I have "Accept-Language: fr,en-US;q=0.7,en;q=0.3". Still not working.

But if I add "Accept-Encoding: gzip, deflate", I get 

GET / HTTP/1.1
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Encoding: gzip, deflate
Accept-Language: en-US,en;q=0.5
Host: m.fool.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: private
Content-Type: application/xhtml+xml; charset=utf-8
Date: Wed, 13 Nov 2013 18:55:54 GMT
P3P: policyref="http://www.fool.com/w3c/p3p.xml", CP="IDC DSP COR CUR ADMa DEVa TAIa CONo HISa TELo OUR PHY ONL UNI PUR FIN COM NAV INT DEM CNT STA PRE LOC IND"
Server: Microsoft-IIS/7.5
Set-Cookie: Visit=visit=7e97c9cc-3092-4eaa-aa51-c32ffc8df6cf; domain=.fool.com; expires=Wed, 13-Nov-2013 19:25:54 GMT; path=/
Set-Cookie: Visitor=visitor=4d66af04-c531-4c6a-bd35-b0b4592754cc&uid=&username=&visits=1&version=3; domain=.fool.com; expires=Mon, 13-Nov-2023 05:00:00 GMT; path=/
Set-Cookie: Sookie=source=NoSource&ybls=0; domain=.fool.com; path=/
Set-Cookie: Wookie=; domain=.fool.com; expires=Thu, 14-Nov-2013 18:55:54 GMT; path=/
Set-Cookie: Tookie=Tookie=&T=18387954831858506873134030965721; domain=.fool.com; expires=Sat, 11-Nov-2023 18:55:55 GMT; path=/
Set-Cookie: v1st=C4EC81F10F31074D; path=/; expires=Wed, 19 Feb 2020 14:28:00 GMT; domain=.fool.com
Set-Cookie: incap_ses_120_92455=RGV+Ofkq5XCw2xr801OqATrLg1IAAAAA3mYZ2F/bBn5ySoEaEIdR6g==; path=/; Domain=.fool.com
Set-Cookie: visid_incap_92455=xGwYy5fPTLel4ltIM3A86jrLg1IAAAAAQUIPAAAAAAA/dmVen2J1g9msOo7O+EI7; expires=Fri, 13 Nov 2015 10:12:50 GMT; path=/; Domain=.fool.com
Transfer-Encoding: chunked
X-AspNetMvc-Version: 2.0
X-CDN: Incapsula
X-Iinfo: 6-10286634-10286635 NNNY CT(27 -1 0) RT(1384368953666 0) q(0 0 0 -1) r(10 10) U2
X-Powered-By: web16

<?xml version="1.0" encoding="UTF-8" ?>
	<!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
	<html xmlns="http://www.w3.org/1999/xhtml"> 
 


Note that the behavior seems not consistent sometimes it fails sometimes not.
(Assignee)

Comment 6

5 years ago
Contacted at http://www.fool.com/help/index.htm?display=EmailSupport
Whiteboard: [serversniff][country-us][contactready] [sitewait] → [serversniff][country-us] [sitewait]
(Assignee)

Comment 7

5 years ago
sent a reminder.
our tests say fixed, I've verified it :)
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.