crash in nsPrintEngine::PrePrintPage

RESOLVED DUPLICATE of bug 886295

Status

()

--
critical
RESOLVED DUPLICATE of bug 886295
5 years ago
5 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, regression})

24 Branch
crash, regression
Points:
---

Firefox Tracking Flags

(firefox23 unaffected, firefox24 affected, firefox25 affected)

Details

(crash signature)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
It started spiking in 24.0a1/20130620. The regression range for the spike is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d2a7cfa34154&tochange=8ea92aeab783
It might be a regression from bug 880854.

Signature 	nsPrintEngine::PrePrintPage() More Reports Search
UUID	92b7a661-4fdb-413f-8ef9-e36342130623
Date Processed	2013-06-23 17:51:30
Uptime	3320
Install Age	2.8 hours since version was first installed.
Install Time	2013-06-23 15:02:35
Product	Firefox
Version	24.0a1
Build ID	20130623031022
Release Channel	nightly
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
Build Architecture	x86
Build Architecture Info	AuthenticAMD family 15 model 107 stepping 2
Crash Reason	EXCEPTION_ACCESS_VIOLATION_WRITE
Crash Address	0x27
App Notes 	
AdapterVendorID: 0x1002, AdapterDeviceID: 0x791e, AdapterSubsysID: 00000000, AdapterDriverVersion: 8.342.0.0
D3D10 Layers? D3D10 Layers- D3D9 Layers? D3D9 Layers- 
Processor Notes 	sp-processor04_phx1_mozilla_com_19736:2012; non-integer value of "SecondsSinceLastCrash"
EMCheckCompatibility	True
Adapter Vendor ID	0x1002
Adapter Device ID	0x791e
Total Virtual Memory	2147352576
Available Virtual Memory	1652625408
System Memory Use Percentage	52
Available Page File	2509549568
Available Physical Memory	1471213568

Frame 	Module 	Signature 	Source
0 	xul.dll 	nsPrintEngine::PrePrintPage 	layout/printing/nsPrintEngine.cpp:2781
1 	xul.dll 	nsPagePrintTimer::Notify 	layout/printing/nsPagePrintTimer.cpp:137
2 	xul.dll 	mozilla::dom::HTMLCanvasPrintState::NotifyDone 	content/html/content/src/HTMLCanvasElement.cpp:109
3 	xul.dll 	nsRunnableMethodImpl<tag_nsresult 	obj-firefox/dist/include/nsThreadUtils.h:350
4 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:626
5 	xul.dll 	NS_ProcessNextEvent 	obj-firefox/xpcom/build/nsThreadUtils.cpp:238
6 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:82
7 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:212
8 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:186
9 	xul.dll 	nsBaseAppShell::Run 	widget/xpwidgets/nsBaseAppShell.cpp:163
10 	xul.dll 	nsAppShell::Run 	widget/windows/nsAppShell.cpp:113
11 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:269
12 	xul.dll 	XREMain::XRE_mainRun 	toolkit/xre/nsAppRunner.cpp:3856
13 	xul.dll 	XREMain::XRE_main 	toolkit/xre/nsAppRunner.cpp:3924
14 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp:4137
15 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp:272
16 	firefox.exe 	NS_internal_main 	browser/app/nsBrowserApp.cpp:632
17 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:105
18 	firefox.exe 	__tmainCRTStartup 	crtexe.c:552
19 	kernel32.dll 	BaseProcessStart 	

More reports at:
https://crash-stats.mozilla.com/report/list?signature=nsPrintEngine%3A%3APrePrintPage%28%29
(Reporter)

Comment 1

5 years ago
Every comments mention printing a PDF file.
status-firefox25: --- → affected

Comment 2

5 years ago
I've got a PDF I can send to anyone who wants to reproduce this, since printing it from pdf.js triggered the crash every time for me.

Comment 3

5 years ago
Created attachment 771510 [details]
Crashing pdf

Actually, it doesn't appear to have any private information on it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 886295
You need to log in before you can comment on or make changes to this bug.