[css3-animations] constant repaints caused by CSS3 animated element outside body

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: myf, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20130906], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 766896 [details]
interactive testcase 01

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20130624 Firefox/24.0 (Nightly/Aurora)
Build ID: 20130624031040

Steps to reproduce:

When animated box exceeds body edge all elements in body are being repainted.


Actual results:

"paintflashing on" while animated element crosses body boundary plays heavy disco.
(Play with attachment.) 


Expected results:

No repaints for animated element (partially or completely) outside body, like it is already for element completely inside body.
(Reporter)

Updated

4 years ago
Attachment #766896 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 1

4 years ago
Confirmed on Nightly 24 & stable 22, 21 @ Win XP, 7, 8, various integrated Intel GMA graphics or AMD Radeons.

Tried on Ubuntu 13.04 on old Celeron M with Intel "915GM" graphic: cannot tell about repaints exactly (developer's tools lacks paintflashing here) but from CPU graph it seems quite opposite: CPU load _drops_ from 100 % to 60 % during animated elements and body intersections. Interesting.

Possibly related: Bug 652397
(Reporter)

Updated

4 years ago
OS: Windows XP → Windows 7
Hardware: x86 → x86_64
Version: unspecified → 25 Branch

Comment 2

4 years ago
Confirmed on Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 @ Kubuntu 12.04.

Comment 3

4 years ago
I can reproduce this bug using Windows 7 64-bit and the latest Nightly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [testday-20130906]
(Reporter)

Comment 4

4 years ago
Todays Fx 26 and recent Nightlies (Win 7, Win 8.1) do not show described behaviour anymore.
So if it isn't the paintflashing mechanism what changed this bug seems fixed to me.

Could anyone recheck this on different platform / GPU?

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Flags: needinfo?
(Reporter)

Comment 5

2 years ago
Marking as resolved: bug haven't occurred since 26 for me (both with and without layers.acceleration.disabled), and apparently no other complaint appeared since then.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.