Closed Bug 886657 Opened 6 years ago Closed 6 years ago

AudioBufferSourceNode starts as soon as it's connected

Categories

(Core :: Web Audio, defect)

18 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
Tracking Status
firefox24 --- fixed
firefox25 --- fixed

People

(Reporter: roc, Assigned: roc)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

This is a pretty bad bug. As soon as the AudioBufferSourceNode's buffer is created and it's connected to the destination, we start playing even if start() hasn't been called yet!
Attachment #767028 - Flags: review?(ehsan) → review+
https://hg.mozilla.org/mozilla-central/rev/ec8ceaf4b03a
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
roc, can you please backport the landed patch to 24?
Flags: needinfo?(roc)
Comment on attachment 767028 [details] [diff] [review]
fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: WebAudio bug
Testing completed (on m-c, etc.): landed for a while
Risk to taking this patch (and alternatives if risky): very low risk
String or IDL/UUID changes made by this patch: none
Attachment #767028 - Flags: approval-mozilla-aurora?
Attachment #767028 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Flags: needinfo?(roc)
Robert, can you please advise QA how to test this?
Flags: needinfo?(roc)
There's an automated test, no QA needed.
Flags: needinfo?(roc) → in-testsuite+
Thanks Robert.
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.