Files re-uploaded with the same version number as a deleted version don't download as expected

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: diegocr, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

5 years ago
https://addons.mozilla.org/en-US/editors/review/amazon-gift-ideas

Checking the diff for the last version of this add-on, that's 1.0.1.0 -> 1.0.5.0, i've noticed the File Viewer showing changes on button.js and keyword.js which didn't really exists as i was able to check by manually downloading the XPI files and comparing them:

http://img109.imageshack.us/img109/308/yo8k.png

(Ie, the checksum for both files are the same on these versions)

However, discussing this with Kris we've realized what happened here is that the extension's author re-submitted the same version number, being that duplicate not showing up on the review page.

Mine:

SHA1(amazon_gift-1.0.5.0-fx.xpi)= 6ea18f121977a33883b66fc3a746c5c330a5562b

Kris:

11584f1de1b38d79655702fee4eb3f293364d789 amazon_gift-1.0.5.0-fx.xpi


Hence, the bug being reported here is from the lack on the review page of such duplicated submission, and what that could imply.
(Reporter)

Updated

5 years ago
Severity: normal → major
Summary: File Viewer is showing changes which does not exists. → Re-submitted extensions with the same version number aren't always shown on the review page.
Hm. I thought we had a bug for this, but the closest I can find is bug 709648.
Component: Admin/Editor Tools → Developer Pages
Summary: Re-submitted extensions with the same version number aren't always shown on the review page. → Files re-uploaded with the same version number as a deleted version don't download as expected
(Reporter)

Comment 2

5 years ago
Oh, so.. deleted versions don't show up on the review page, just when two versions are physically uploaded/available? Urgh.
Deleted versions only show up on the review page when they have reviews. There are log entries for them, though, so that could be fixed.

Updated

5 years ago
Duplicate of this bug: 891387
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
There were some major changes done recently that essentially block duplicate uploads, even for previously-deleted versions. This shouldn't be a problem anymore (for new submissions).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.