Closed Bug 886749 Opened 7 years ago Closed 7 years ago

[Camera] Run out of memory for video capturing

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+)

RESOLVED WORKSFORME
1.1 QE3 (26jun)
blocking-b2g leo+

People

(Reporter: leo.bugzilla.gaia, Assigned: gduan)

Details

Attachments

(1 file)

Attached image Screenshot attached
1. Title : Run out of memory for video capturing
2. Precondition : No space in both internal memory and external memory and Camera app should be working
3. Tester's Action : 1. Open camera
                     2. Capture video
 
4. Detailed Symptom (ENG.) : If user try to capture video, then there is no indication to user even when there is no memory available and also, the captured video will not be saved.

5. Expected : If memory is less than minimum recording size before recording the video, prevent the video to get recorded and display error notification. 
Also, if user is recording video and memory reduces less than the minimum recording size, then stop recording and save the video with an error notification.

6.Reproducibility: Y
1)Frequency Rate : 100%
7.Gaia Master/v1-train : Reproduced
8.Gaia Revision: 65e861f5941cab66815a2f79b0bc0a6a0fc8f6fe
9.Personal email id: gjyothiprasad@gmail.com
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Target Milestone: --- → 1.1 QE3 (24jun)
Assignee: nobody → gduan
Priority: -- → P2
Hi ,

You have mentioned two bugs in 5.expected , 
first is when run out of memory and trying to entering camera app, no error notification displaying .
second is when recording video and very close to running out of memory, no error notification displaying , no automatically stop ,and the video is not saved.

I cannot reproduce the first error, so I am guessing it's second one, right?
Flags: needinfo?(gjyothiprasad)
also cannot reproduce it on Leo device.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Hi,

I am also not able to reproduce this issue with latest leo software.
Hi,

I am also not able to reproduce this issue with latest leo software.
Flags: needinfo?(gjyothiprasad)
You need to log in before you can comment on or make changes to this bug.