If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crashes while zooming in pdf.js

RESOLVED DUPLICATE of bug 853959

Status

()

Firefox
PDF Viewer
P3
critical
RESOLVED DUPLICATE of bug 853959
4 years ago
4 years ago

People

(Reporter: martinstingl, Unassigned)

Tracking

({crash})

21 Branch
x86
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130511120803

Steps to reproduce:

Viewing the file http://www.farnell.com/datasheets/1655829.pdf, zoom in and out. 


Actual results:

pdf.js showed an error: (Windows 7 32Bit, latest Firefox)

    PDF.js v0.8.259 (build: d744be4)
    Message: Failure
    File: http://mozilla.github.io/pdf.js/build/pdf.js
    Line: 3567

It also happens that the complete Firefox window did not get redrawed showing mostly black areas. Somtimes switching to other tabs was very slow and lead to random crashes of Firefox.

This is maybe related to a graphic card driver problem.
Here ist the "about:support" output:

Graphics
        Adapter DescriptionIntel(R) Q45/Q43 Express ChipsetAdapter Driversigdumdx32 igd10umd32Adapter RAMUnknownClearType ParametersGamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 Device ID0x2e12Direct2D EnabledtrueDirectWrite Enabledtrue (6.1.7601.17789)Driver Date2-11-2011Driver Version8.15.10.2302GPU #2 ActivefalseGPU Accelerated Windows1/1 Direct3D 10Vendor ID0x8086WebGL RendererGoogle Inc. -- ANGLE (Intel(R) Q45/Q43 Express Chipset)

        
        AzureCanvasBackenddirect2dAzureContentBackenddirect2dAzureFallbackCanvasBackendcairo

        
        Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414Failed to create texture for data Error code: 2147942414

Comment 1

4 years ago
No error for me in the web console for Firefox 22, the current Release version.
What about you?
Component: Untriaged → PDF Viewer
Flags: needinfo?(martinstingl)
Could you also provide the link to the crash from the url about:crashes ?
Priority: -- → P3
Whiteboard: [pdfjs-f-need-info]
(Reporter)

Comment 3

4 years ago
After upgrading to Firfox 22 the error massage has change a little:
>PDF.js v0.8.265 (build: 8561d26)
>Message: Failure
>File: http://mozilla.github.io/pdf.js/build/pdf.js
>Line: 3567

After zooming to 400%, zooming out and in again, there was no image rendered (white background for 1 second), then a black colour is shown. Switching to other tabs sometimes makes parts of the Firefox window to not be redrawn (black tab bars etc, see attachment black_box.png) and also has lead to crashes of Firefox (at least with Firefox version 21).

Here is the link:
https://crash-stats.mozilla.com/report/index/bp-ad8e1b0f-0edc-4c82-8ba4-6baac2130625
Flags: needinfo?(martinstingl)
(Reporter)

Comment 4

4 years ago
Created attachment 767611 [details]
Black areas in Firefox window

Comment 5

4 years ago
I still can't reproduce.
Does it happen in Safe Mode (see https://support.mozilla.org/kb/troubleshoot-firefox-issues-using-safe-mode)?
Severity: normal → critical
Crash Signature: [@ CDevice::ID3D10Device1_ClearRenderTargetView_(ID3D10Device1*, ID3D10RenderTargetView*, float const* const) ]
Flags: needinfo?(martinstingl)
Keywords: crash
Whiteboard: [pdfjs-f-need-info]
(Reporter)

Comment 6

4 years ago
The error also happens in Safe Mode.
This is probably related to a problem with the graphic card driver, so easy reproducing may not be possible.

(Previously I had a pdf.js problem that some images could not be shown - an graphic card driver update in Windows solved that issue but a guys at pdf.js mentioned that this should not happen anyhow)
Flags: needinfo?(martinstingl)

Comment 7

4 years ago
(In reply to martinstingl from comment #6)
> The error also happens in Safe Mode.
> This is probably related to a problem with the graphic card driver, so easy
> reproducing may not be possible.
Safe Mode turns off HW acceleration so I don't think so.

Does it happen with a new profile (see https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles)?
Flags: needinfo?(martinstingl)
(Reporter)

Comment 8

4 years ago
It happens also with a new profile.
Flags: needinfo?(martinstingl)

Comment 9

4 years ago
Please update your graphics drivers, the latest version for your GPU is 8.15.10.2869 (one year younger than yours): https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration
Then report back.
Flags: needinfo?(martinstingl)
(Reporter)

Comment 10

4 years ago
I updated the graphic driver to 8.15.10.2869.
The error message of pdf.js remains.
Playing a little with fast zoom-in and -out crashed Firefox again, see:
https://crash-stats.mozilla.com/report/index/bp-6bc4bb20-d884-4b0e-afb0-454952130626
Flags: needinfo?(martinstingl)

Comment 11

4 years ago
(In reply to martinstingl from comment #3)
> >PDF.js v0.8.265 (build: 8561d26)
It's odd. The PDF.js version in 22.0 is 0.7.423 and the one in Nightly is 0.8.229. It's the development version in https://github.com/mozilla/pdf.js.
How can it be be possible as it happens in Safe Mode that disable extensions?
Can you reinstall Firefox above your current version?

(In reply to martinstingl from comment #10)
> https://crash-stats.mozilla.com/report/index/bp-6bc4bb20-d884-4b0e-afb0-
> 454952130626
It's bug 853959.
Blocks: 853959
Crash Signature: [@ CDevice::ID3D10Device1_ClearRenderTargetView_(ID3D10Device1*, ID3D10RenderTargetView*, float const* const) ] → [@ CDevice::ID3D10Device1_ClearRenderTargetView_(ID3D10Device1*, ID3D10RenderTargetView*, float const* const) ] [@ DrawingContext::DrawBitmap(ID2D1Bitmap*, D2D_RECT_F const*, float, D2D1_BITMAP_INTERPOLATION_MODE, D2D_RECT_F const*) ]
Flags: needinfo?(martinstingl)
(Reporter)

Comment 12

4 years ago
For my last comment I did not use Safe Mode.

Now using Safe Mode:
When using the built-in PDF.js I cannot produce error messages but when zooming fast (with the mouse wheel) sometimes there are no images shown, just the grey/orange border of the mentioned PDF file.

With PDF.js from github the following message appears sometimes, sometimes showing no PDF content:
>PDF.js v0.8.265 (build: 8561d26)
>Message: Failure
>File: http://mozilla.github.io/pdf.js/build/pdf.js
>Line: 3567
Flags: needinfo?(martinstingl)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 853959
You need to log in before you can comment on or make changes to this bug.