Remove --disable-libpr0n and USE_IMG2 ifdefs

RESOLVED FIXED in mozilla1.0.1

Status

RESOLVED FIXED
18 years ago
14 years ago

People

(Reporter: cls, Assigned: Biesinger)

Tracking

Trunk
mozilla1.0.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 6 obsolete attachments)

(Reporter)

Description

18 years ago
 
(Reporter)

Comment 1

18 years ago
Created attachment 40863 [details] [diff] [review]
Remove --disable-pr0n and USE_IMG2 from unix & win32 builds.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 2

18 years ago
Requesting mac help to remove this cruft.

Comment 3

18 years ago
This is easy on mac, just tell me when it is safe to try.

Comment 4

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 5

17 years ago
*** Bug 131046 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
cls/saari: any hope in getting all the patches & finally removing this anytime 
soon?
Created attachment 98292 [details] [diff] [review]
content/ part of USE_IMG2 removal

removes USE_IMG2 from content/
also removes a variable that was only used if USE_IMG2 was not defined
there are also USE_IMG2 uses in gfx/ which I'm too lazy to fix now
Comment on attachment 98292 [details] [diff] [review]
content/ part of USE_IMG2 removal

r=caillon
Attachment #98292 - Flags: review+

Comment 12

16 years ago
Comment on attachment 98292 [details] [diff] [review]
content/ part of USE_IMG2 removal

sr=tor
Attachment #98292 - Flags: superreview+

Comment 13

16 years ago
Comment on attachment 98293 [details] [diff] [review]
layout/ part

sr=tor
Attachment #98293 - Flags: superreview+
Comment on attachment 98292 [details] [diff] [review]
content/ part of USE_IMG2 removal

checked in
Attachment #98292 - Attachment is obsolete: true
Comment on attachment 98293 [details] [diff] [review]
layout/ part

checked in
Attachment #98293 - Attachment is obsolete: true
taking bug
Assignee: pavlov → cbiesinger
Status: ASSIGNED → NEW
Created attachment 105875 [details] [diff] [review]
remove USE_IMG2 ifdefs in gfx/

Comment 18

16 years ago
Comment on attachment 105875 [details] [diff] [review]
remove USE_IMG2 ifdefs in gfx/

r=walk84
Attachment #105875 - Flags: review+
Comment on attachment 105875 [details] [diff] [review]
remove USE_IMG2 ifdefs in gfx/

bz, could you super-review? easy to do, just a bit of ifdef removal.
Attachment #105875 - Flags: superreview?(bzbarsky)
Comment on attachment 105875 [details] [diff] [review]
remove USE_IMG2 ifdefs in gfx/

The rendering context api has the IMG2 DrawImage calls and the other set as
well... are both used?	Should both be present?  Can one be eliminated?

In addition, I would prefer that _someone_ (either the r= or the sr=) who
reviews this patch know something about gfx.  I know I don't, really, and I
suspect neither does walk84.  I would not feel comfortable putting my sr on
this patch as-is.
Attachment #105875 - Flags: superreview?(bzbarsky) → superreview-

Comment 21

16 years ago
http://lxr.mozilla.org/seamonkey/search?string=%5C%3EDrawImage%5C%28
reveals these are being used:
714   NS_IMETHOD DrawImage(nsIImage *aImage, nscoord aX, nscoord aY,
715                        nscoord aWidth, nscoord aHeight) = 0; 

721   NS_IMETHOD DrawImage(nsIImage *aImage, const nsRect& aRect) = 0;

and if you include the throbber sample (which I wouldn't), this one's being used:

705   NS_IMETHOD DrawImage(nsIImage *aImage, nscoord aX, nscoord aY) = 0;


_looks_like_ DrawImage(nsIImage *aImage, const nsRect& aSRect, const nsRect&
aDRect) is not being used
these last two functions that you mentioned are indeed not used, not on linux at
least - my tree compiles with them commented out.

I'll look ta the other things later.
Created attachment 109769 [details] [diff] [review]
ok, let's remove some unused functions

this patch removes some unused DrawImage and DrawTile functions, and related
stuff
Created attachment 109771 [details] [diff] [review]
as last patch, but also remove unneeded #include

same as the last "remove unused functions" patch, but here I also remove some
#include "nsIImage.h" and a "class nsIImage;" forward declaration.
Attachment #109769 - Attachment is obsolete: true
cc'ing some people who might be interested in the last patch here (which is
basically a cleanup of nsIRenderingContext)
Comment on attachment 109771 [details] [diff] [review]
as last patch, but also remove unneeded #include

I'll review this
Attachment #109771 - Flags: superreview?(roc+moz)
Attachment #109771 - Flags: review?(roc+moz)
Looks good, just a couple of questions:
1) Why haven't you removed the actual USE_IMG2 #ifdefs in nsIRenderingContext?
2) Please fix the throbber test.
Other than that --- thank you, thank you, thank you!
*** Bug 186158 has been marked as a duplicate of this bug. ***
Comment on attachment 105875 [details] [diff] [review]
remove USE_IMG2 ifdefs in gfx/

sr=roc+moz
Attachment #105875 - Flags: superreview- → superreview+
Comment on attachment 109771 [details] [diff] [review]
as last patch, but also remove unneeded #include

r+sr=roc+moz after biesi pointed out that the throbber code is in #if 0

Strictly speaking I'm not a GFX peer but I do know GFX and for this trivial
stuff, it doesn't matter.
Attachment #109771 - Flags: superreview?(roc+moz)
Attachment #109771 - Flags: superreview+
Attachment #109771 - Flags: review?(roc+moz)
Attachment #109771 - Flags: review+
Status: NEW → ASSIGNED
ok, the last two non-obsolete patches here are checked in now.


leaving open for the final removal of USE_IMG2 from the build system
Created attachment 109898 [details] [diff] [review]
Final USE_IMG2 removal

(marking the checked in patches obsolete)
Attachment #40863 - Attachment is obsolete: true
Attachment #105875 - Attachment is obsolete: true
Attachment #109771 - Attachment is obsolete: true
Attachment #109898 - Flags: review?(seawood)
Comment on attachment 109898 [details] [diff] [review]
Final USE_IMG2 removal

r=cls
Attachment #109898 - Flags: review?(seawood) → review+
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.