Web Apps/App Templates Firefox OS Denied Public Key

RESOLVED FIXED

Status

Developer Documentation
General
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: ShellHacker, Assigned: sheppy)

Tracking

Details

(URL)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0 (Beta/Release)
Build ID: 20130512194445

Steps to reproduce:

Clone the App-Stub firefox OS template for development using the following command

$ git clone git@github.com:mozilla/mortar-app-stub.git myapp


Actual results:

Cloning into 'myapp'...
The authenticity of host 'github.com (204.232.175.90)' can't be established.
RSA key fingerprint is 16:27:ac:a5:76:28:2d:36:63:1b:56:4d:eb:df:a6:48.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'github.com,204.232.175.90' (RSA) to the list of known hosts.
Permission denied (publickey).
fatal: The remote end hung up unexpectedly



Expected results:

The repository should've been cloned successfully.
(Reporter)

Updated

5 years ago
You should clone using the https:// protocol, otherwise it fails because you might not have permissions to access with git://

I see it is updated now in the MDN page, though. Could you please try to reproduce it? If it doesn't happen any more we can close this as fixed :-)
(Reporter)

Comment 2

4 years ago
I think shifting to https:// solves a lot of problems. I figured out that I filed this issue because back then I was behind a proxy firewall which has SSH disabled, Using https:// solves the issue.

Closing this issue as resolved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.