Closed Bug 887125 Opened 6 years ago Closed 6 years ago

Allow 0 for Memory GC Preferences

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25

People

(Reporter: gwagner, Assigned: gwagner)

References

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 file, 1 obsolete file)

Attached patch patch (obsolete) — Splinter Review
In Bug 863398 we set javascript.options.mem.gc_high_frequency_low_limit_mb to 0 but the SetMemoryGCPrefChangedCallback only allows values > 0.
Attachment #767588 - Flags: review?(bent.mozilla)
Duplicate of this bug: 887178
Comment on attachment 767588 [details] [diff] [review]
patch

Review of attachment 767588 [details] [diff] [review]:
-----------------------------------------------------------------

There need to be worker changes here too.
Attachment #767588 - Flags: review?(bent.mozilla)
Duplicate of this bug: 887519
Attached patch patchSplinter Review
Assignee: general → anygregor
Attachment #767588 - Attachment is obsolete: true
(In reply to ben turner [:bent] from comment #2)
> Comment on attachment 767588 [details] [diff] [review]
> patch
> 
> Review of attachment 767588 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> There need to be worker changes here too.

No we don't :)
Attachment #768112 - Flags: review?(bent.mozilla)
Comment on attachment 768112 [details] [diff] [review]
patch

Review of attachment 768112 [details] [diff] [review]:
-----------------------------------------------------------------

\o/
Attachment #768112 - Flags: review?(bent.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/a37c6d91463f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.