Closed Bug 887169 Opened 6 years ago Closed 6 years ago

Style issues in Chrome - help?

Categories

(Webmaker Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 883461

People

(Reporter: laura, Unassigned)

Details

Since I transferred the stylesheet for all the kits to S3, Chrome doesn't seem to read it. 

In Chrome, look at:
the make on webmaker.org: https://mozteach.makes.org/thimble/hacking-guide-make-it-share-it

the make at it's previous home (same server as the css): http://hivenyc.org/storycamp/weeks05and06/index_popcorn05_plan.html

I'm guessing all Mozteach makes look like crap in Chrome (I checked three and then cried).
I think I know what caused this.

When we updated the details page to be an iframe, we set that iframe source to be https which is going to fail as there is no https for that css file.

Chrome is strict with mixing http and https links in one document. It doesn't load your css because it is http and the rest of the page is https.

https://stuff.webmaker.org/teach-assets/kits/styles.css "webpage is not available"

Can we have that hosted on both http and https?

Should we not be building that iframe link form https?
Flags: needinfo?(pomax)
Flags: needinfo?(jon)
deferring to jbuck - we filed an issue on this yesterday, can't find it atm.
Hmmm, because this is pointing at S3 specifically right now, I cannot apply https to it.

Jbuck, we had chatted about a page that will proxy in content, using the ugly s3 https url to keep end to end, but make it pretty to Laura and the users.

Is that still going to be the long term solution?

For now, Laura Hilliger, you can use this url in your page: https://s3.amazonaws.com/stuff.webmaker.org/teach-assets/kits/styles.css
Note: that original make has mixed-content issues in FF nightly as well.
As :jp points out, you can use that url to fix the immediate mixed content issues.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(pomax)
Flags: needinfo?(jon)
Resolution: --- → DUPLICATE
Duplicate of bug: 883461
Component: Projects → General
You need to log in before you can comment on or make changes to this bug.