Installing mozilla 0.92 disables launching Internet Explorer window when clicking on link in Microsoft Outlook

VERIFIED WORKSFORME

Status

SeaMonkey
Installer
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: gerry-list, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    2001062815



Reproducible: Always
Steps to Reproduce:
1. Installing mozilla 0.92 installer
2. Open Outlook 2000
3. Click a link in an e-mail

Actual Results:  If an Internet Explorer window is not already open, an blank 
internet explorer window will open with no url.

If an Internet explorer window is already open, nothing will happen.

Expected Results:  Internet Explorer should load the url

Did not occur with previous milestone builds. Uninstalling mozilla does not 
help. Reasonably sure this happened because of mozilla.

Comment 1

17 years ago
Cant you just disable it in the Edit -> Preferences -> System?
Did you answeer yes to "Should this appl handle internet shortcuts" ?
(Reporter)

Comment 2

17 years ago
None of the boxes in Preferences/System are checked. And remember, it's not
mozilla opening up the links. Clicking on them does nothing in Outlook. However,
it did not break IE .url files.

Comment 3

17 years ago
gerry,
If you are confident with windows, you could check the registry with regedit 
and see what HKEY_CLASSES_ROOT\http\shell\open\command points to.

On my system where mozilla handles all protocols, this points at mozilla.exe. I 
would imagine that this is probably what is examined when you click on a link 
in Outlook.
(Reporter)

Comment 4

17 years ago
HKEY_CLASSES_ROOT\http doesn't exist. I don't know why it doesn't. But the thing
worked before installing mozilla 0.9.2
(Reporter)

Comment 5

17 years ago
Correction: it is there. The value was

"c:\Program Files\Internet Explorer\iexplore.exe" -nohome

So I changed it to:

"c:\Program Files\Internet Explorer\iexplore.exe %s"

And I clicked a link in Outlook, and it presented me with a file dialog box 
asking which program it should use. I choose the path to iexplore.exe

So now it works...and here it gets real strange:

I delete the value HKEY_CLASSES_ROOT\http\shell\open\command and even 
restart...and it still works!

And https...didn't work. Deleted value...and it works, only it didn't even ask 
which program to use!
Gerry, based on your comments I'm resolving this as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.