Closed Bug 887210 Opened 7 years ago Closed 7 years ago

cannot activate the provider (sidebar shows connect error)

Categories

(Firefox Graveyard :: SocialAPI, defect)

24 Branch
x86_64
Linux
defect
Not set

Tracking

(firefox22 unaffected, firefox23+ verified, firefox24+ verified, firefox25+ verified)

VERIFIED FIXED
Firefox 25
Tracking Status
firefox22 --- unaffected
firefox23 + verified
firefox24 + verified
firefox25 + verified

People

(Reporter: em, Assigned: mixedpuppy)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

Activation of a social provider results in a sidebar which shows a "connection" error. This is possibly related to bug 887206, perhaps the same underlying issue, but this bug focuses on the inability to activate the first time, which is more critical.

1. Start with a clean profile
2. Goto https://mozsocial.cliqz.com/
3. Activate
4. Sidebar shows error "Nightly is unable to connect with Cliqz right now"

Restarting Firefox fixes the problem. This problem started to appear in version 25.0a1 (2013-06-25).
Regression range:
good=2013-06-18
bad=2013-06-19
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4e5983de6e3b&tochange=d2a7cfa34154

Suspected bug:
Gavin Sharp — Bug 879658: avoiding exposing localStorage to non-whitelisted social providers, r=mixedpuppy
Blocks: 879658
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 25 Branch → 24 Branch
Duplicate of this bug: 887206
(In reply to Loic from comment #1)
> Regression range:
> good=2013-06-18
> bad=2013-06-19
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=4e5983de6e3b&tochange=d2a7cfa34154
> 
> Suspected bug:
> Gavin Sharp — Bug 879658: avoiding exposing localStorage to non-whitelisted
> social providers, r=mixedpuppy

Are you able to reproduce this always?  I've never seen it.  Did you look for an console messages?
I get a "localStorage" is not defined error (sorry, copy in the error console doesn't work).

I don't any error when I restart though.
(In reply to Shane Caraveo (:mixedpuppy) from comment #3)
> Are you able to reproduce this always?  I've never seen it.  Did you look
> for an console messages?

Yes, 100% reproducible.

Browser console when I click to activate cliqz:
[16:21:19.435] FrameWorker: Error evaluating worker script for SocialProvider:https://mozsocial.cliqz.com: ReferenceError: localStorage is not defined; Line #160
@https://mozsocial.cliqz.com/worker?version=1.0:160
 @ resource://gre/modules/FrameWorker.jsm:258
Assignee: nobody → mixedpuppy
Attachment #767754 - Flags: review?(gavin.sharp)
Comment on attachment 767754 [details] [diff] [review]
fix blessed state on activation and update

I thought addProvider was only called in tests :( Thanks for chasing this down.

nit: add a space to line up the two "activationType"s
Attachment #767754 - Flags: review?(gavin.sharp) → review+
fix xpcshell tests
Attachment #767754 - Attachment is obsolete: true
Attachment #767842 - Flags: review+
better fix with gavins feedback

https://tbpl.mozilla.org/?tree=Try&rev=4fbb2e2670f4
Attachment #767842 - Attachment is obsolete: true
Attachment #768039 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/016160c72517
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
Comment on attachment 768039 [details] [diff] [review]
fix blessed state on activation and update

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 879658
User impact if declined: activation of new providers fails
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, no real alternative other than backing out bug 879658
String or IDL/UUID changes made by this patch: none
Attachment #768039 - Flags: approval-mozilla-beta?
Attachment #768039 - Flags: approval-mozilla-aurora?
Attachment #768039 - Flags: approval-mozilla-beta?
Attachment #768039 - Flags: approval-mozilla-beta+
Attachment #768039 - Flags: approval-mozilla-aurora?
Attachment #768039 - Flags: approval-mozilla-aurora+
Samvedana, please verify this is fixed in Firefox 23, 24, and 25.
Keywords: verifyme
QA Contact: samvedana.gohil


User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Build ID : 20130708202947

Tested on Firefox 23-B4, I don't see any connection error. I can activate Social Demo Provider.

User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:25.0) Gecko/20130711 Firefox/25.0
Build ID:20130711030204

Tested on latest nightly, I don't see any connection error. I can activate Social Demo Provider.
User Agent : Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20130711 Firefox/24.0
Build ID : 20130711004005

Tested on latest Aurora, I don't see any connection error. I can activate Social Demo Provider.
Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0
Build ID: 20130812173056

Verified as fixed on Firefox 24 beta 2 - the Social Demo is activated (no connect errors are displayed in the sidebar).
Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20130912004004

Verified as fixed on Firefox 25.0a2.
Status: RESOLVED → VERIFIED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.