Closed Bug 887224 Opened 9 years ago Closed 9 years ago

elmundo.es/movil2 doesn't display correctly in Gaia browser

Categories

(Web Compatibility :: Mobile, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: efrat, Unassigned)

References

()

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

Steps to reproduce:

Browsed to "http://www.elmundo.es/movil2/" from Gaia browser

Tested on:
1.  Firefox OS simulator
OS version 1.1.0.0-prerelease
Build Identifier 20130522133646

User Agent String is:
Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

2.  Model: ZTE Open
OS version: 1.0.1.0-prerelease
Firmware: V1.01.00.01.019.117
Platform:18.0
Build identifier: 20130528094315


Actual results:

In the simulator - The site uploads as a desktop site and not mobile adjusted

On a device- The site uploads as a desktop site and not mobile adjusted (same)



Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly on Firefox for Android and Chrome for Android
I get a desktop site in Chrome and the Android stock browser. Can you please attach a screenshot that shows the mobile content that you expect to see?
Attached image Screenshot from Android
The site displays correctly as a mobile site on Firefox for Android and Chrome for Android
Displays correctly as a mobile site on Firefox for Android and Chrome for Android
Lawrence, your screenshot indicates you are getting the mobile version (font sizes, header and menu styling, dimensions..). According to my very bad Spanish, the site asks to change your cookie settings in order to browse it correctly.
(In reply to Ran Ben Aharon (Everything.me) from comment #6)
> Lawrence, your screenshot indicates you are getting the mobile version (font
> sizes, header and menu styling, dimensions..). According to my very bad
> Spanish, the site asks to change your cookie settings in order to browse it
> correctly.

Yes. Apologies for the confusion. I think I omitted the path in my initial test run. I do see mobile content. The issue now is that the content appears broken in Firefox.
Still, I would like to make sure that the FxOS browser loads the mobile version instead of the desktop one, since it's a major site in Spain and Latin America.
seems OK in FxOS on my Geeksphone Peak
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.