Open Bug 88725 Opened 19 years ago Updated 7 years ago

a Toolbar Button to Show / Hide Sidebar

Categories

(SeaMonkey :: UI Design, enhancement)

x86
Windows 98
enhancement
Not set

Tracking

(Not tracked)

People

(Reporter: izel, Unassigned)

References

Details

For many people, Mozilla is finally becoming a valid IE alternative. In order to
convince longtime IE users to make the switch, it makes sense to cater to some
of their UI habits through toggleable features, as long as implementing the
features does not take too much time or does not require a redesign.

In IE, a standard and often-used toolbar has buttons to show / hide the Search,
Favorites, and History sidebars. In Mozilla, one can show / hide the sidebar by
going to View / My Sidebar, or by pressing F9. (Maybe there are other options as
well.) However, one very noticeably missing option is the lack of a Sidebar
toolbar button. The available toolbar buttons are: Bookmarks, Go, Home, Search,
Print. As a longtime IE user who is conditioned to click on a toolbar button to
see his history, search results, etc, on the sidebar, this lack of a Sidebar
button was very disorienting to me. I am confident that it will be similarly
disorienting, or at least annoying, to a significant number of expert web
surfers brought up on IE.

Hopefully including an extra toolbar button on the same row as the Go, Search
and Print buttons won't cause too much pain. It will definitely increase
usability for me and people like me.

One side effect is that themes will need to be updated to accomodate this
change. But what's one extra button when you've designed an entire theme?
there was a bug to put a button for this in the component bar, would that be 
satisfactory? otherwise this bug is future (blocked by implementation of 
customizable toolbars)
If I understand the term correctly, the component bar is the row of tiny icons at the bottom of the browser window.

This is quite counterintuitive to the placement of the Search, History, Favorites icons in IE (at the top, within close proximity of the URL bar). In IE, the icons activating Search, History, Favorites, etc, can be moved around and placed above, beside, or below the URL bar.

If the current design makes it difficult to implement this until later, then so be it.

I also think that it would be semantically sketchy to put a Sidebar icon beside the icons for Navigator, Composer, Address Book, etc. All the other component bar icons are for separate applications (or come across as such) while the Sidebar is just a part of the Navigator (or come across as such).

If I am misunderstanding the component bar reference, please correct me.
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Proposing a Toolbar Button to Show / Hide Sidebar → [RFE] a Toolbar Button to Show / Hide Sidebar
two things : 

1)i think we can mark this bug fixed. In build 200202403 i now have an extra
button to open/close the side bar.

2) I do have one cosmetic suggestion :
Currently RED means opening the sidebar, GREEN is closing it. Somehow, these
colors  seem very counter-intuitive.

*** Bug 152821 has been marked as a duplicate of this bug. ***
please don't use the 'rfe' keyword. some people's convenience is
becoming annoyance for those who use bugzilla everyday.
Summary: [RFE] a Toolbar Button to Show / Hide Sidebar → a Toolbar Button to Show / Hide Sidebar
n7 has this. i turned it off.
Assignee: mpt → blaker
Component: User Interface Design → XP Apps: GUI Features
QA Contact: zach → paw
Isn't it nice to be able to turn something off *IF* you don't want it!!!

Why this was removed from mozilla is beyond me.
*** Bug 172670 has been marked as a duplicate of this bug. ***
dup of bug 134345?
*** Bug 139962 has been marked as a duplicate of this bug. ***
Sorry. This is NOT a dup of bug 134345. That one is verified fixed, but
allthough the summary and product indicates it has something to do with Mozilla,
the bug was only about work that had to be done in Mozilla in order to make the
buton work in NETSCAPE. Well done.
CCing self.

Since I don't use Netscape, I don't know whether it has a 'sidebar toggle
button'.  If it does, it would seem like a very sensible feature.  Why doesn't
Mozilla have this?  The sidebar's a very major feature, and worthy of a button;
I didn't even know about it until somebody told be about it, and now have to use
F9 to toggle it open and closed (that border thing that pushes it to/pulls it
from the side of the screen just isn't intuative enough).

I would suggest a good placement for this button would be in the 'navigation
toolbar', to the left of the 'print this page' button.  Before people start
saying that this bar is solely for navigation-related stuff:
1) 'Print this page' is hardly navigation-related.
2) Why shouldn't it incorporate one or two major other features (such as sidebar
toggle), and be renamed 'General toolbar'?  Seems like a good idea to me :-)

Please add a 'toggle sidebar' button into Mozilla.  This enhancement request has
my vote.
Netscape 7 does have the Show/Hide Sidebar button (and it's quite nice, might I
add). I think that this was removed from Mozilla for performance reasons.
Reassigning obsolete bugs to their respective Seamonkey owners (i.e. nobody). 
If you want this fixed for Firefox, change the Product and Component accordingly
and reassign back to me.
Assignee: firefox → guifeatures
Product: Core → Mozilla Application Suite
I'm going thru my subscribed bugs, doing a bit of a 'cleanup'.

For those who are subscribed to this bug and haven't died of old age yet... ;-)... has it been fixed, and is it now even relevant as the Suite has been replaced with Seamonkey, has it not?  Is this bug still relevant for Seamonkey?
Un-CCing; this will probably never get fixed and I'm no longer concerning myself with the old Moz suite.
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: pawyskoczka → guifeatures
Component: XP Apps: GUI Features → UI Design
Many a few people asked this function in the forum.
http://forums.mozillazine.org/viewtopic.php?f=4&t=2088539
http://forums.mozillazine.org/viewtopic.php?f=19&t=3620

A defunct draft add-on called Sidebar Toggle exist (http://downloads.mozdev.org/cdn/sbartoggle/)
You need to log in before you can comment on or make changes to this bug.