Last Comment Bug 887370 - Add privacy policy generator text/links to submission privacy policy section
: Add privacy policy generator text/links to submission privacy policy section
Status: RESOLVED DUPLICATE of bug 1055790
[repoman][contribute]
:
Product: Marketplace
Classification: Server Software
Component: Developer Pages (show other bugs)
: 1.0
: All All
: P3 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 11:09 PDT by Daniel Buchner [:dbuc]
Modified: 2014-10-02 10:17 PDT (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Mock for implementation (317.12 KB, image/png)
2013-06-26 11:09 PDT, Daniel Buchner [:dbuc]
no flags Details
privacyTooltip.jpg (190.53 KB, image/jpeg)
2013-08-15 13:48 PDT, Tony Santos [:tsmuse]
no flags Details

Description Daniel Buchner [:dbuc] 2013-06-26 11:09:42 PDT
Created attachment 767881 [details]
Mock for implementation

Please modify the text to reflect what is show in the mock, and add the links to the following privacy policy generators: Iubenda - https://www.iubenda.com/en/mobile, PrivacyChoice - http://privacychoice.org/policymaker
Comment 1 Wil Clouser [:clouserw] 2013-06-26 11:22:24 PDT
It looks like those sites have a narrow set of languages they offer.  Are you only wanting to show those links in English?
Comment 2 Wil Clouser [:clouserw] 2013-06-28 08:32:49 PDT
Talked to dbuc.  He is designing a new landing page with legal and will update this bug when he has a place for us to link to.
Comment 3 Daniel Buchner [:dbuc] 2013-07-09 11:29:15 PDT
(In reply to Wil Clouser [:clouserw] from comment #2)
> Talked to dbuc.  He is designing a new landing page with legal and will
> update this bug when he has a place for us to link to.

Here's the content legal would like us to go with: https://docs.google.com/file/d/1AmZNEuU9Zxuhg0aO3wxffW6oE-UGBRCdZGQ9cUS6sJHXmCd0FuTIImfHnzXZ/edit?usp=sharing

They've decide we can just show this as a modal that is shown in the context of the privacy policy section in the submission flow.
Comment 4 Wil Clouser [:clouserw] 2013-07-10 11:22:29 PDT
(In reply to Daniel Buchner [:dbuc] from comment #3)
> They've decide we can just show this as a modal that is shown in the context
> of the privacy policy section in the submission flow.

What does this mean?
Comment 5 Daniel Buchner [:dbuc] 2013-07-23 11:26:28 PDT
(In reply to Wil Clouser [:clouserw] from comment #4)
> (In reply to Daniel Buchner [:dbuc] from comment #3)
> > They've decide we can just show this as a modal that is shown in the context
> > of the privacy policy section in the submission flow.
> 
> What does this mean?

When the user clicks the links, as show in the mockup, show the content provided in a modal. The content will live in the Marketplace, not on Mozilla.org (the legal team couldn't get that larger page ready in time)
Comment 6 Wil Clouser [:clouserw] 2013-07-23 11:44:04 PDT
Thanks.  Is there a time constraint on this bug I don't know about?

Squeezing this into a modal is more work for everyone (engineering, QA, L10n [twice], etc.).  The content you have here is documentation so it seems like it should go with all our other documentation on the devhub and we should just link to that and avoid the modal altogether.  Is the landing page you're talking about something you're trying to get in the devhub w/ Fred and is that blocked on something?
Comment 7 Daniel Buchner [:dbuc] 2013-07-23 17:02:33 PDT
(In reply to Wil Clouser [:clouserw] from comment #6)
> Thanks.  Is there a time constraint on this bug I don't know about?
> 
> Squeezing this into a modal is more work for everyone (engineering, QA, L10n
> [twice], etc.).  The content you have here is documentation so it seems like
> it should go with all our other documentation on the devhub and we should
> just link to that and avoid the modal altogether.  Is the landing page
> you're talking about something you're trying to get in the devhub w/ Fred
> and is that blocked on something?

Legal is working on a larger privacy policy solution - but for now, they gave us this content to help developers in the submission flow who need privacy policy info/generators. I guess we can put this on DevHub, but I was thinking a modal would be a easier/better temporary solution (if the page gets index on Dev Hub, we have to maintain a link/redirect - removing a modal that sits behind an auth flow presents no such issues)
Comment 8 Wil Clouser [:clouserw] 2013-07-23 19:49:58 PDT
Temporary things tend to be pretty permanent around here and it's a pretty big engineering difference.  Fred - do you have a place on the devhub where this content would go?
Comment 9 Tony Santos [:tsmuse] 2013-08-15 13:48:02 PDT
Created attachment 790937 [details]
privacyTooltip.jpg

I agree with Wil that temporary things tend to stick around a long time, and I also agree with Dan that we don't want to rip people out of the flow to read documentation. I'd like to suggest the following "solution" for this pending all the other projects that are in flux around the submission flow and devhub, including another usability test we're prepping to run. If this solution needs to be tweaked in the future, we'll get more direction from the future usability tests because the Privacy Policy stuff tends to steal the show even when we're not testing for it.

I'll take the content legal has provided in the PDF linked above and add it as a page to MDN under the apps section. This is going to further our efforts of migrating dev hub content to MDN. In the flow we can provide a tooltip (see attached sketch) that gives users a summary of the info included in Dan's initial mock, but we'll also include a link to the MDN page that opens in a new tab, if they want to read more. That way we give them a chunk of useful data in the flow, that's out of the way and will continue to be useful, even if we come up with a better documentation solution down the line. 

Thoughts? I can work on what the box will actually say if this is the direction we want to move in.
Comment 10 Wil Clouser [:clouserw] 2013-08-15 15:24:06 PDT
Sounds good to me.  I'm not sure those hover boxes support links right now, but I assume it'll work.
Comment 11 Tony Santos [:tsmuse] 2013-08-28 12:53:10 PDT
I've added the document to MDN at: https://developer.mozilla.org/en-US/docs/Web/Apps/Publishing/Privacy_Policies_for_Open_Web_Apps

I'm not sure that there's any more work on my end for this one...
Comment 12 Andy McKay [:andym] 2014-09-04 13:52:38 PDT
This seems to be pretty easy to link to the MDN page, could be a popup or just a bit of text under the privacy policy.
Comment 13 Jared Kerim [:jkerim] 2014-10-02 10:17:21 PDT

*** This bug has been marked as a duplicate of bug 1055790 ***

Note You need to log in before you can comment on or make changes to this bug.