[L10n][cs]: Marketplace categories aren't yet fully translated

RESOLVED FIXED in 2013-07-11

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sarsenyev, Assigned: clouserw)

Tracking

2013-07-11
ARM
Gonk (Firefox OS)
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 767903 [details]
screenshot attachment

Description:
When a language set up to "Czech", the Marketplace categories are still in English

Repro Steps:
1) Updated to Buri/Inari/Leo/Unagi Build ID: 20130621070212
2) In the "Settings" change a language to "Czech"
3) Open "Marketplace" app from the home screen
4) Tap on "All Categories" option

Actual:
The "Categories" menu aren't translated to the target language

Expected:
All "Categories" menus are translated to the target language

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a34f6d62cb05
Gaia: cca61224e6df8e9f7e450d77cb6a8cf91029be64
Platform Version: 18.1

Notes:
Repro frequency: 100%
See the screenshot attachment

Updated

5 years ago
Component: General → Consumer Pages
Product: Boot2Gecko → Marketplace
Version: unspecified → 1.0
Hi Wil,

Czech is one of the next waves of locales to be released in FFOX.  We would like to enable cs too.  I see that it is mostly translated but there is no .mo file.  Is that the reason that it is not displayed right now? 
https://github.com/mozilla/fireplace/blob/master/locale/cs/LC_MESSAGES/messages.po
Assignee: nobody → clouserw
(Assignee)

Comment 2

5 years ago
No, fireplace doesn't use .mo files.

Categories are translated via the web at the old localizer dashboard (https://addons.mozilla.org/en-US/localizers/cs/categories/).  It looks like most of these categories are localized though.  If they were translated recently it may be working its way through cache.  If not, the cache may be a little too aggressive.

Basta - if you get a chance do you have an easy way to bust this cache?  Otherwise this bug may fix itself if it just needs to expire.

Comment 3

5 years ago
Clearing memcached would be the easiest way, but that's generally a bad plan. If the translation is there, it should start showing up soon-ish.

Updated

5 years ago
Duplicate of this bug: 888996

Updated

5 years ago
Duplicate of this bug: 888996

Updated

5 years ago
Summary: [B2G][l10n][Marketplace] Czech: Marketplace categories aren't translated to the target language → Marketplace categories aren't yet fully translated
(Assignee)

Comment 6

5 years ago
Reassigning to nobody@.  I don't know what the problem is here, but it's not missing translations.

Category translations exist on addons.mozilla.org/cs/ and they exist for most of the marketplace categories in the db.  I doubt this is memcache since it's been weeks.
Assignee: clouserw → nobody
We've had a similar problem before: https://bugzilla.mozilla.org/show_bug.cgi?id=874926
Assignee: nobody → clouserw
Summary: Marketplace categories aren't yet fully translated → [L10n][cs]: Marketplace categories aren't yet fully translated
I will mark this bug fixed for now per issue of the original report.  There are a couple of strings pending translation, but overall, the category status looks good.  

https://marketplace-dev.allizom.org/?lang=cs/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → 2013-07-11
You need to log in before you can comment on or make changes to this bug.