Last Comment Bug 887422 - padding-bottom is ignored with "calc" height
: padding-bottom is ignored with "calc" height
Status: RESOLVED DUPLICATE of bug 748518
:
Product: Core
Classification: Components
Component: Layout: Block and Inline (show other bugs)
: unspecified
: x86_64 Linux
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 12:10 PDT by Mike Pennisi [:jugglinmike]
Modified: 2013-06-26 12:14 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Mike Pennisi [:jugglinmike] 2013-06-26 12:10:23 PDT
When CSS `height` is defined with the `calc` function, the value of `padding-bottom` is ignored, i.e.:

.container {
  height: calc(50px);
  padding-bottom: 50px;
}

Platform: Firefox Nightly 25.0a1 (2013-06-25)

Demo: http://jsbin.com/upixig/1/edit
Comment 1 User image Mike Pennisi [:jugglinmike] 2013-06-26 12:14:24 PDT
Upon further investigation, I've found that the use of `calc` is irrelevant. Specifying "overflow" triggers this behavior, which as bug 748518 documents, is expected.

*** This bug has been marked as a duplicate of bug 748518 ***

Note You need to log in before you can comment on or make changes to this bug.