spirentcom.com works only with document.layers and document.all

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
18 years ago
4 years ago

People

(Reporter: chrisch, Assigned: doronr)

Tracking

Details

(Whiteboard: [PROPRIETARY-DOM][dw][aok], URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001062815

Notice moving mouse upand down on business units produces a slow redraw of the
center graphic. Also, the News section does not render at all. Cross checked
aginst IE 5.5, works 100%.

Thx.

Reproducible: Always
Steps to Reproduce:
1.Go to http://www.spirentcom.com/
2.Move mouse over business units
3. Observe that the center graphic does not redraw quickly

Actual Results:  Slow redraw; no rendering of "News" section on page

Expected Results:  Draw center grapic quickly, render news section

Comment 1

18 years ago
The "no rendering of news"-issue is an evangelism.
The page checks

if (document.layers)
	document.write(messages[1]);
if (document.all)
        ...

Netscape uses Layers, Microsoft Internet Explorer uses document.all.
Mozilla (a non-proprietary software =) uses neither of them.

Comment 2

18 years ago
The slow redraw works for me 2001063008 w2k
-> Evangelism.

Changing summary from "Mozilla renderer does not render parts of the site
corectly" to "spirentcom.com works only with document.layers and document.all"
Status: UNCONFIRMED → NEW
Component: Viewer App → Evangelism
Ever confirmed: true
Summary: Mozilla renderer does not render parts of the site corectly → spirentcom.com works only with document.layers and document.all
Reassigning owner and QA contact.
Assignee: rickg → bclary
QA Contact: rickg → zach

Updated

18 years ago
OS: Windows 2000 → All
Priority: -- → P2
Hardware: PC → All
Whiteboard: [PROPRIETARY-DOM]
(Reporter)

Comment 5

18 years ago
That may be true, but if Mozilla wishes to compete, it must be compatible with 
what is out there.

Comment 6

17 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 7

17 years ago
dreamweaver, needs to upgrade
Whiteboard: [PROPRIETARY-DOM] → [PROPRIETARY-DOM][dw]
(Assignee)

Comment 8

17 years ago
part of it uses dw, part a self written scroller
Blocks: 51020
Whiteboard: [PROPRIETARY-DOM][dw] → [PROPRIETARY-DOM][dw][aok]

Comment 9

17 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Comment 10

16 years ago
All sections of the page now render as in IE, checked 20030513 PC/WinXP.
No script calling document.layers/all is present.  Page was apparently corrected.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.