Firefox 22 : no more plasma notifications on kde 4.

RESOLVED DUPLICATE of bug 858919

Status

()

RESOLVED DUPLICATE of bug 858919
5 years ago
5 years ago

People

(Reporter: kokoko3k, Unassigned)

Tracking

22 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130626010747

Steps to reproduce:

Installed firefox 22, completed a download.


Actual results:

I saw an ugly notifications on the wrong screen (i'm dual head) saying me that the download was completed


Expected results:

in a linux/kde environment, every notifications was displayed by a plasma widget until (including) firefox 21.

Now not only this does not happen anymore, but the ugly notification box appears even on the wrong "head" on a multihead setup (nvidia twinview)

Comment 1

5 years ago
Could you use the tool mozregression to find a possible regression range as you're able to reproduce the issue.
See http://harthur.github.io/mozregression/ for details.

FF22 nightlies started in Feb. 2013 (mozregression --good=2013-02-01).
Flags: needinfo?(kokoko3k)
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

5 years ago
Sure, i'd like to do it, but pip throws me an error:
http://pastebin.com/GpsmRgP5
here pip.log:
http://pastebin.com/pFahJcge

If you could point me to a list of packages to download and install, i could bisect manually.
Flags: needinfo?(kokoko3k)

Comment 3

5 years ago
This is by design, I believe. It's caused by bug 782211, which replaced native notifications with ugly XUL notifications. :(

See also bug 858919 and bug 853104.

The notification appearing on the wrong screen sounds like a valid bug though.
(Reporter)

Comment 4

5 years ago
Damn, you are 99.999% right, see comment 13:
https://bugzilla.mozilla.org/show_bug.cgi?id=782211#c13

Is there something we could do?

(oh, still, the notification appears on the wrong screen to me)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858919

Comment 6

5 years ago
File a new bug if the new notifications are displayed on the wrong display.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.