Bootstrap fails to install clang on macports

RESOLVED FIXED in mozilla25

Status

defect
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: BenWa, Assigned: gps)

Tracking

unspecified
mozilla25
x86
macOS
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Posted file log
No description provided.
I just updated macports and it appears mp-clang is no longer a package name. I'm guessing it was removed in the last few months? clang-3.2 and clang-3.3 are valid package names, however.

Patch should be trivial.
Component: mach → Build Config
Summary: Bootstrap fails to install clang on 10.7 → Bootstrap fails to install clang on macports
Since you can reproduce this, I'm delegating review power to you.
Attachment #768478 - Flags: review?(bgirard)
Assignee: nobody → gps
Comment on attachment 768478 [details] [diff] [review]
Don't use mp-clang in MacPorts bootstrapper

Review of attachment 768478 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine to me but rebooting to my 10.7 partition is going to take a bit of my time so I'd rather not test this ATM. I imagine landing this wont make it worse but let me know if you want me to test it first.

For the record 10.7 is useful since Valgrind doesn't support 10.8 yet.
Attachment #768478 - Flags: review?(bgirard) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/aeb89583349d
Status: NEW → ASSIGNED
Flags: in-testsuite-
Target Milestone: --- → mozilla25
https://hg.mozilla.org/mozilla-central/rev/aeb89583349d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This change broke bootstrap.py for me and at least one other person. See bug 878607.
Depends on: 878607
I also see the breakage reported by :jwatt. I believe this change was incorrect and should be reverted. The MacPorts package name is clang-2.3, but it is installed as mp-clang-2.3 to avoid overwriting existing copies of clang (see http://trac.macports.org/ticket/29171). As osx.py is using MacPorts, we should be using the MacPort-installed mp-clang-2.3.
(In reply to Arthur Edelstein from comment #7)
> I also see the breakage reported by :jwatt. I believe this change was
> incorrect and should be reverted. The MacPorts package name is clang-2.3,
> but it is installed as mp-clang-2.3 to avoid overwriting existing copies of
> clang (see http://trac.macports.org/ticket/29171). As osx.py is using
> MacPorts, we should be using the MacPort-installed mp-clang-2.3.

Can you please add your findings to bug 878607?
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.