Closed Bug 887826 Opened 7 years ago Closed 7 years ago

Reduce per-thread Pseudostack overhead on b2g

Categories

(Core :: Gecko Profiler, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla25
Tracking Status
firefox22 --- unaffected
firefox23 - affected
firefox24 --- affected

People

(Reporter: BenWa, Assigned: BenWa)

References

Details

(Whiteboard: [MemShrink:P1])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #872947 +++

We allocate a Pseudostack for each registered thread (Main, Compositor, workers thread) of 40KB because we always maintain a consistent Pseudostack. This overhead is to high for mobile. The problem is that allocating this structure when we start profiling is too late.

For now we can disable multi-threaded profiling on b2g since it's not ready to be used yet.
Whiteboard: [MemShrink:P2] → [MemShrink]
Benoit, can you do this ASAP?
Whiteboard: [MemShrink] → [MemShrink:P1]
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #773024 - Flags: review?(jseward)
Attachment #773024 - Flags: review?(jseward) → review+
https://hg.mozilla.org/mozilla-central/rev/cb30c2681fe3
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
You need to log in before you can comment on or make changes to this bug.