evalInSandbox:Error: Permission denied for <https://facebook.com> to create wrapper for object of class UnnamedClass

RESOLVED INVALID

Status

()

Firefox
Untriaged
--
critical
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Jeff Wolfe, Unassigned)

Tracking

22 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Has anyone even looked at this yet? 06/27/2013 7:24pm EDT)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 768349 [details]
20130627  JBW Troubleshooting Information.xht

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

1.  I opened Firefox browser.
2.  It automatically updated my browser and extensions to version 22.0
3.  I opened my toolbar link for Facebook

As soon as I opened any page on facebook.com, I get the error noted in the summary


Actual results:

evalInSandbox:Error: Permission denied for <https://facebook.com> to create wrapper for object of class UnnamedClass 

I click ok  and it returns again

evalInSandbox:Error: Permission denied for <https://facebook.com> to create wrapper for object of class UnnamedClass

I click ok a second time and it seems to stop for the page I am on; however if I go to any other page, the same error occurs.   I'm running the latest Java as well (Version 7; Update 25


Expected results:

Here is Troubleshooting page directly from Help/Troubleshooting Information:



  Application Basics

        Name
        Firefox

        Version
        22.0

        User Agent
        Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        AVG SafeGuard toolbar
        15.2.0.5
        true
        avg@toolbar

        eCleaner
        1.4
        true
        {c72c0c73-4eb0-4fb3-af0f-074e97326cfd}

        Fasterfox
        3.9.81
        true
        {c36177c0-224a-11da-8cd6-0800200c9a91}

        FireFTP
        2.0.16
        true
        {a7c6cf7f-112c-4500-a7ea-39801a327e5f}

        Flash and Video Download
        1.34
        true
        {bee6eb20-01e0-ebd1-da83-080329fb9a3a}

        Flash OnOff
        0.3.1
        true
        jid0-XXocAsQYPfKHSY8ebTi0VcX8eNQ@jetpack

        Google Analytics Opt-out Browser Add-on
        0.9.6
        true
        {6d96bb5e-1175-4ebf-8ab5-5f56f1c79f65}

        ImTranslator
        5.5
        true
        {9AA46F4F-4DC7-4c06-97AF-5035170634FE}

        LastPass
        2.0.20
        true
        support@lastpass.com

        QuickJava
        1.8.0
        true
        {E6C1199F-E687-42da-8C24-E7770CC3AE66}

        Social Fixer
        7.501
        true
        socialfixer@mattkruse.com

        Speed Dial
        0.9.6.15
        true
        {64161300-e22b-11db-8314-0800200c9a66}

        StartAid Online Bookmarks
        1.4.6
        true
        startaid@startaid.com

        Viral Threat Level
        0.54
        true
        viralthreatlevel@serevinus.com

        FoodBuzz
        9.0
        false
        {2326C1C3-3E92-49da-A3FB-CB8AD8AD8F25}

        ZoneAlarm Security Engine
        1.5.393.22
        false
        {FFB96CC1-7EB3-449D-B827-DB661701C6BB}

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        358400

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size.use_old_max
        false

        browser.cache.disk.smart_size_cached_value
        358400

        browser.places.smartBookmarksVersion
        4

        browser.startup.homepage
        http://www.ighome.com/

        browser.startup.homepage_override.buildID
        20130618035212

        browser.startup.homepage_override.mstone
        22.0

        browser.tabs.warnOnClose
        false

        browser.urlbar.autocomplete.enabled
        false

        dom.mozApps.used
        true

        dom.w3c_touch_events.expose
        false

        extensions.lastAppVersion
        22.0

        font.internaluseonly.changed
        true

        gfx.blacklist.direct2d
        4

        gfx.blacklist.layers.direct3d9
        4

        gfx.direct3d.prefer_10_1
        true

        keyword.URL
        http://isearch.fantastigames.com/web?src=ffb&gct=ds&appid=107&systemid=465&q=

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1372273805

        places.history.expiration.transient_current_max_pages
        69806

        plugin.disable_full_page_plugin_for_types
        application/pdf

        plugin.importedState
        true

        plugin.state.npdeployjava
        0

        privacy.cpd.offlineApps
        true

        privacy.cpd.siteSettings
        true

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.timeSpan
        0

        storage.vacuum.last.index
        1

        storage.vacuum.last.places.sqlite
        1370363625

  Graphics

        Adapter Description
        AMD Radeon HD 6250 Graphics

        Adapter Drivers
        aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64

        Adapter RAM
        384

        ClearType Parameters
        Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 300

        Device ID
        0x9804

        Direct2D Enabled
        Blocked for your graphics card because of unresolved driver issues.

        DirectWrite Enabled
        false (6.2.9200.16492)

        Driver Date
        6-7-2011

        Driver Version
        8.862.0.0

        GPU #2 Active
        false

        GPU Accelerated Windows
        0/1 Basic Blocked for your graphics card because of unresolved driver issues.

        Vendor ID
        0x1002

        WebGL Renderer
        Google Inc. -- ANGLE (AMD Radeon HD 6250 Graphics  )

        AzureCanvasBackend
        skia

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        cairo

  JavaScript

        Incremental GC
        true

  Accessibility

        Activated
        false

        Prevent Accessibility
        0

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9.6
        4.9.6

        NSS
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSSMIME
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSSSL
        3.14.3.0 Basic ECC
        3.14.3.0 Basic ECC

        NSSUTIL
        3.14.3.0
        3.14.3.0
(Reporter)

Updated

5 years ago
Severity: normal → critical
(Reporter)

Updated

5 years ago
Whiteboard: Has anyone even looked at this yet? 06/27/2013 7:24pm EDT
(Reporter)

Comment 1

5 years ago
Apparently when Mozilla updated to the latest version, there were left over code items from the Add On "Social Fixer".   AFter reinstalling Social Fixer after the latest Mozilla Firefox is installed, there were no more javascript errors.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.