OutdatedDataErrors shouldn't return a 500 error

RESOLVED DUPLICATE of bug 922625

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 922625
4 years ago
4 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [balrog])

(Reporter)

Description

4 years ago
Anything that causes an OutdatedDataError currently returns a 500 error. This isn't right because the server hasn't done anything wrong - the client simply lost a race.

The annoying thing about this is that Sentry gets notified of each one of these without good reason. The client retries anyways, so these aren't really indicative of a problem.

Looks like 409 ("Conflict") is the right thing to send.
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
(Reporter)

Comment 1

4 years ago
In bug 922625 we started sending a 400 for them. 409 might be better, but it really doesn't matter in reality...
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 922625
You need to log in before you can comment on or make changes to this bug.