Closed Bug 887896 Opened 8 years ago Closed 8 years ago

Regression: Focussing address bar does not show & select URL

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: benfrancis, Assigned: benfrancis)

References

Details

Attachments

(1 file)

Regression caused by bug 817876

STR:
* Open browser
* Load google.com
* Focus address bar

Expected:
* Address bar shows the text http://google.com and the text is selected

Actual:
* User is able to edit title of page

Patch coming.
blocking-b2g: --- → leo?
This bug doesn't exist on v1-train
blocking-b2g: leo? → ---
Comment on attachment 768446 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/10677

So I searched through the history and it appears that code may not be needed, we only trigger urlFocus on user input which is impossible with the dialogs are they are full modal, tad worrying though (ie we need to start getting into a comfortable testing state)
Attachment #768446 - Flags: review?(dale) → review+
Merged in: https://github.com/mozilla-b2g/gaia/commit/37f38d23574628672cee71b6942e870d6c078455
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Thanks for the review. I think that code was just legacy from before the visual design was applied to modal dialogs to make them full screen.

I think the underlying issue is really that the code in ModalDialog is a bit fragile and doesn't deal with edge cases or null values very well, this patch was just a quick fix for the regression but as discussed elsewhere we should probably aim to improve this area of code over time with unit tests.
Duplicate of this bug: 888968
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.