Closed Bug 887951 Opened 6 years ago Closed 6 years ago

Update panel menu button tooltip

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: MattN, Assigned: manishearth)

References

(Blocks 1 open bug)

Details

(Whiteboard: [strings][Australis:P4][good first bug][mentor=jaws][lang=js][good first verify])

Attachments

(1 file, 5 obsolete files)

"Customize and Control UX" isn't user-friendly.
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P4]
To fix this bug, you'll need to clone the repository at https://hg.mozilla.org/projects/ux/.

Matej, clicking on this button brings the user to the "Firefox" menu, which allows for making changes to Firefox (Full Screen, Preferences, Customize) as well as operating Firefox (New Window, Save Page, Exit) etc. Can you think of something better than "Customize and Control brandShortName"?
Flags: needinfo?(Mnovak)
Whiteboard: [Australis:M?][Australis:P4] → [Australis:M?][Australis:P4][good-first-bug][mentor=jaws][lang=js]
Whiteboard: [Australis:M?][Australis:P4][good-first-bug][mentor=jaws][lang=js] → [Australis:M?][Australis:P4][good first bug][mentor=jaws][lang=js]
Can I get a little more context as to where this appears and what the issue is with the current string? Thanks.
Flags: needinfo?(Mnovak)
This appears when hovering over the menu button in Nightly UX builds.

Matt filed the bug, so I'll defer to him about what is wrong with the current string.
Flags: needinfo?(mnoorenberghe+bmo)
Matej - if you come over to my desk, I can show you the tooltip in context.
I call this button the "Menu Button" in that it brings up the menu.

One approach would be to have the tooltip just reflect that -- i.e., "Menu," "Tools Menu," or "Firefox Menu."

Another would be to be more descriptive -- i.e., "Tools and Customization."
I think something like the options in comment 5 could work, I just worry that "tools" may not be the best descriptor. Maybe something like "preferences" instead?

My other thought was to make this more actionable and less descriptive. It could even be, dare I say it, a tad whimsical.

Maybe it's something like "Mission control" or "Tweaks & fiddles."

I believe mconley is also reaching out to product marketing so we can all get on the same page about what this menu should be called — whether or not we use that for the tooltip.
(In reply to Matej Novak [:matej] from comment #6)
> I believe mconley is also reaching out to product marketing so we can all
> get on the same page about what this menu should be called — whether or not
> we use that for the tooltip.

What I ended up doing was asking in the Australis weekly meeting, which got Madhava in here. Asa was also in the call, and didn't pipe up mentioning a particular name that Product was interested in pushing, so I think Madhava's data is stuff we can run with.
To be honest, when I filed the bug, I thought that "UX" was hard-coded as a temporary tooltip and not &brandShortName;. The other aspect was that I thought it was putting a bit too much emphasis on customization considering that it's not a very common task.
Flags: needinfo?(mnoorenberghe+bmo)
While somewhat boring, I think "Firefox Menu" or simply "Menu" is the most straightforward.
Attached patch Patch 0.1 (obsolete) — Splinter Review
Changed text to "Tools and Customization"
Attachment #795041 - Flags: review?(jaws)
Attached patch 887951.patch (obsolete) — Splinter Review
Oops, forgot to edit in the directory in the previous patch (had a build running, so I couldn't hg at the root level and had to edit the diff manually).
Attachment #795041 - Attachment is obsolete: true
Attachment #795041 - Flags: review?(jaws)
Attachment #795060 - Flags: review?
Attachment #795060 - Flags: review? → review?(jaws)
Comment on attachment 795060 [details] [diff] [review]
887951.patch

I'm not sure if we've settled on a name yet.

The options so far are:
1. Tools and Customization
2. Customize and control Firefox
3. Customize and Control Firefox
4. Mission control
5. Tweaks & fiddles
6. Menu

Madhava, I'll let you make the call here. Which one should we use?
Attachment #795060 - Flags: review?(jaws) → feedback?(madhava)
Manish, Madhava is on vacation for the next two weeks, so I'm not expecting an answer very soon from him.

I will try to find another bug for you to work on in the meantime, so far your first patch looks good!
(In reply to Jared Wein [:jaws] from comment #12)
You forgot some from Madhava in comment 5:
> The options so far are:
> 1. Tools and Customization
> 2. Customize and control Firefox
> 3. Customize and Control Firefox
> 4. Mission control
> 5. Tweaks & fiddles
> 6. Menu
  7. Firefox Menu
  8. Tools Menu

> Madhava, I'll let you make the call here. Which one should we use?
Assignee: nobody → manishsmail
Status: NEW → ASSIGNED
Alright, thanks :)
Any decision on this yet?
Flags: needinfo?(madhava)
Whiteboard: [Australis:M?][Australis:P4][good first bug][mentor=jaws][lang=js] → [strings][Australis:P4][good first bug][mentor=jaws][lang=js]
We should look at this together with the extra tip in bug 870593.

Where by we, I mean I. And Mnovak.
Flags: needinfo?(madhava)
Madhava and I chatted about this today and here's what we came up with:

Open menu
> Open menu


Isn't that a bit redundant?
Attached patch open.menu.patch (obsolete) — Splinter Review
Patch for "open menu"
Attachment #8365494 - Flags: review?(madhava)
Attachment #795060 - Attachment is obsolete: true
Attachment #795060 - Flags: feedback?(madhava)
Comment on attachment 8365494 [details] [diff] [review]
open.menu.patch

Since this is a code change, it's best to let a developer look at this. That, and Jared is your mentor on this one!
Attachment #8365494 - Flags: review?(madhava) → review?(jaws)
Ah, I thought the code change had been vetted, it was just the wording change that mattered.

Thanks.
Comment on attachment 8365494 [details] [diff] [review]
open.menu.patch

Review of attachment 8365494 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Manish, thanks for the patch. Because this text has been on mozilla-central already, we'll need to also change the entity name in the dtd. You can use appmenu.title2
Attachment #8365494 - Flags: review?(jaws) → review-
Attached patch tooltip.patch (obsolete) — Splinter Review
Changed all instances of `appmenu.title` to `appmenu.title2` to trigger l10n changes.
Attachment #8365494 - Attachment is obsolete: true
Attachment #8365950 - Flags: review?(jaws)
Comment on attachment 8365950 [details] [diff] [review]
tooltip.patch

>       <toolbaritem id="PanelUI-button"
>                    class="chromeclass-toolbar-additional"
>                    removable="false"
>-                   title="&appmenu.title;">
>+                   title="&appmenu.title2;">
>         <toolbarbutton id="PanelUI-menu-button"
>                        class="toolbarbutton-1"
>                        label="&brandShortName;"
>-                       tooltiptext="&appmenu.title;"/>
>+                       tooltiptext="&appmenu.title2;"/>
>       </toolbaritem>

As far as I can tell, the title attribute on the toolbaritem node is completely useless; you should drop it and call the entity appmenu.tooltip.
Attachment #8365950 - Flags: review?(jaws) → review-
Attached patch tooltip.patch (obsolete) — Splinter Review
Attachment #8365950 - Attachment is obsolete: true
Attachment #8366007 - Flags: review?(jaws)
Attachment #8366007 - Flags: feedback?(dao)
Attachment #8366007 - Flags: review?(jaws)
Attachment #8366007 - Flags: review+
Attachment #8366007 - Flags: feedback?(dao)
What does this bug have to do with customization mode? O.o
Flags: needinfo?(mconley)
Whoops - typed in the wrong bug number. Thanks for the catch. :)
No longer depends on: 964322
Flags: needinfo?(mconley)
Comment on attachment 8366007 [details] [diff] [review]
tooltip.patch

>Bug 887951 - Update panel menu button tooltip; r=jaws

nit: r=dao since I ended up granting you review
Attached patch tooltip.patchSplinter Review
Attachment #8366125 - Flags: review?(dao)
Comment on attachment 8366125 [details] [diff] [review]
tooltip.patch

thanks, this wouldn't have needed another review
Attachment #8366125 - Flags: review?(dao) → review+
Attachment #8366007 - Attachment is obsolete: true
Whiteboard: [strings][Australis:P4][good first bug][mentor=jaws][lang=js] → [strings][Australis:P4][good first bug][mentor=jaws][lang=js][fixed-in-fx-team]
...aaand backed out because it didn't have Australis in the commit message.

https://hg.mozilla.org/integration/fx-team/rev/4744ddc205df

and then relanded with a better commit message:

https://hg.mozilla.org/integration/fx-team/rev/14063a5b30e2
https://hg.mozilla.org/mozilla-central/rev/14063a5b30e2
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [strings][Australis:P4][good first bug][mentor=jaws][lang=js][fixed-in-fx-team] → [strings][Australis:P4][good first bug][mentor=jaws][lang=js]
Target Milestone: --- → Firefox 29
Whiteboard: [strings][Australis:P4][good first bug][mentor=jaws][lang=js] → [strings][Australis:P4][good first bug][mentor=jaws][lang=js][good first verify]
You need to log in before you can comment on or make changes to this bug.