Status

()

Core
General
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: rnewman, Unassigned)

Tracking

Trunk
All
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
08:40:32 < kats> libxul went from 22348744 in the fennec-22 APK to 47072268 in the fennec-23 AP

This has essentially doubled our APK size. That's bad.

Filing this so that someone who knows can move this to the right place…
We should be certain that we're comparing before and after szipping.

Comment 2

5 years ago
* are we still compressing?
* are we still stripping?

Not knowing anything about APK, are they just zip files? Does this regression show up in Nightly and can we figure out which nightly build caused it?

Comment 3

5 years ago
Build team: assemble!
Flags: needinfo?(mh+mozilla)
Related to bug 887902?
Flags: needinfo?(mh+mozilla)
So, if I look at the fennec 23b1 (beta) apk, libxul is 23089012, when it was 22348744 in 22. That doesn't seem very wrong.

If I look at the fennec 23a2 (aurora) apk, libxul is 47054993, which is expected, since we set STRIP_FLAGS="--strip-debug" (which doesn't strip symbols) in mobile/android/config/mozconfigs/android/nightly, but not in mobile/android/config/mozconfigs/android/release. Beta tinderbox builds also use mobile/android/config/mozconfigs/android/nightly.

Move along, nothing to see :)
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.