Closed Bug 888089 Opened 8 years ago Closed 8 years ago

topcrasher CSV broken (looking for is_gc_count)

Categories

(Socorro :: Webapp, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rhelmer, Assigned: rhelmer)

References

Details

https://crash-stats.mozilla.com/topcrasher/products/Firefox/versions/25.0a1/crash_type/report/os_name/browser?format=csv is failing

https://errormill.mozilla.org/webtools/socorro-crashstats-prod/group/16587/

KeyError: 'is_gc_count'

Stacktrace (most recent call last):

  File "django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)
  File "crashstats/crashstats/decorators.py", line 48, in inner
    return view(request, *args, **kwargs)
  File "session_csrf/__init__.py", line 127, in wrapper
    response = f(request, *args, **kw)
  File "crashstats/crashstats/decorators.py", line 32, in inner
    return view(request, *args, **kwargs)
  File "crashstats/crashstats/views.py", line 309, in topcrasher
    return _render_topcrasher_csv(request, context, product)
  File "crashstats/crashstats/views.py", line 343, in _render_topcrasher_csv
    crash['is_gc_count'],
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 889447
Target Milestone: --- → 53
Target Milestone: 53 → 52
Hmm actually the commit in comment 3 should have had a different bug # - sorry about that. It really fixes problems like bug 888089
You need to log in before you can comment on or make changes to this bug.