If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SideMenuWidget displays tooltips that simply say 'undefined'.

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools
P2
normal
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: anton, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I'm using custom nodes as items for SideMenuWidget. AFAIK, there's no way for me to set a description property on my items and because of that the resulting UI has a tooltip that says "undefined" (to reproduce simply hover over any profile item in the Profiler sidebar).

I think the widget should a) not set tooltiptext property if its undefined and b) allow me to set descriptions when using custom DOM nodes.
Yup, should be fixed by bug 887203.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to Anton Kovalyov (:anton) from comment #0)
> 
> I think the widget should a) not set tooltiptext property if its undefined
> and b) allow me to set descriptions when using custom DOM nodes.

You now can, after bug 884006:
> .push([customNode, someValue, descriptionAsTooltip]);
You need to log in before you can comment on or make changes to this bug.