[B2G][MMS][Regression] We are skipping 'sending' status when sending a MMS

RESOLVED FIXED in Firefox 25, Firefox OS v1.1hd

Status

()

Core
DOM: Device Interfaces
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: borjasalguero, Assigned: Gene Lian (I already quit Mozilla))

Tracking

(Blocks: 1 bug, {regression})

unspecified
mozilla25
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:leo+, firefox23 wontfix, firefox24 wontfix, firefox25 fixed, b2g18 fixed, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 wontfix, b2g-v1.1hd fixed)

Details

(Whiteboard: [fixed-in-birch])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When sending a SMS without SIM Card we have the status: 'sending' to 'failed/error'. However in MMS we go directly to 'failed/error', so we have a inconsistency. Gaia code is handling the flow 'sending' to  'sent'/'error' (depending on if it was successful or not), so this inconsistency is breaking the SMS App.
(Reporter)

Comment 1

5 years ago
Dietrich, Could you take a look? This is breaking completely the SMS App without SIM... leo+?
blocking-b2g: --- → leo?
(Reporter)

Updated

5 years ago
Flags: needinfo?(dietrich)
(Reporter)

Comment 2

5 years ago
Gene, could you take a look? Thanks!
Flags: needinfo?(gene.lian)
(Reporter)

Updated

5 years ago
Keywords: regression
(Assignee)

Updated

5 years ago
Assignee: nobody → gene.lian
Flags: needinfo?(gene.lian)
(Assignee)

Comment 3

5 years ago
This is a regression due to Bug 880561. Patch is coming.
(Assignee)

Comment 4

5 years ago
Created attachment 768762 [details] [diff] [review]
Patch

I believe ctai's review is sufficient. No time to wait for Vicamo's review. Let's land this quickly.
Attachment #768762 - Flags: review?(ctai)
Attachment #768762 - Flags: review?(ctai) → review+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/projects/birch/rev/3c694e99184f

Waiting on leo+ tag to land this to b2g18.
Whiteboard: [fixed-in-birch]
https://hg.mozilla.org/mozilla-central/rev/3c694e99184f
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla25
(Assignee)

Comment 7

5 years ago
Ping Dietrich?
(Assignee)

Updated

5 years ago
Blocks: 744684
(Reporter)

Updated

5 years ago
Depends on: 880257
(Reporter)

Comment 8

5 years ago
This is needed for having https://bugzilla.mozilla.org/show_bug.cgi?id=880257 working, otherwise this feature is not complete. We need leo+ here for fixing the entire issue. Leo+?
Regression in mms -> blocking+.
blocking-b2g: leo? → leo+
Flags: needinfo?(dietrich)
(Assignee)

Comment 10

5 years ago
Thanks Dietrich!

https://hg.mozilla.org/releases/mozilla-b2g18/rev/74d81af73f5d
status-b2g18: --- → fixed
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → wontfix
status-b2g-v1.1hd: --- → affected
status-firefox25: --- → fixed
https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/74d81af73f5d
status-b2g-v1.1hd: affected → fixed
status-firefox23: --- → wontfix
status-firefox24: --- → wontfix
(Reporter)

Updated

5 years ago
Blocks: 888903
You need to log in before you can comment on or make changes to this bug.