Closed Bug 888151 Opened 7 years ago Closed 7 years ago

[clock] In a Alarmlist Alarm label and days of Repeat overlap.

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:leo+, b2g18 verified, b2g-v1.1hd fixed)

RESOLVED FIXED
1.1 QE4 (15jul)
blocking-b2g leo+
Tracking Status
b2g18 --- verified
b2g-v1.1hd --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: leo.bugzilla.gaia)

References

Details

(Keywords: regression, Whiteboard: [LeoVB+])

Attachments

(3 files)

Attached image screen shot attached
1. Title : In a Alarmlist Alarm label and days of Repeat overlap.
2. Precondition :1.Enter all 50 charater in label field.
                 2.select 6 days mon,tue,wed,thur.fri,sat in Repeat.
3. Tester's Action :Alarm>>New Alarm>> Enetre 50 character in Label >> Select 6 days in Repeat.
4. Detailed Symptom (ENG.) :When we eneter 50 character in label field and select 6 days in repeat then days and label overlap in Alarmlist. 
5. Expected :In Alarmlist after one line label should be truncted.
6. Reproducibility: Y
1)Frequency Rate : 100%
Assignee: nobody → mihai
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Priority: -- → P1
Target Milestone: --- → 1.1 QE4 (15jul)
please check the patch for v1-train for this issue.
Attachment #769648 - Flags: review?(iliu)
Hi Leo, if you were working on this you should have set the 'Assigned to:' field :)
Assignee: mihai → nobody
Assignee: nobody → leo.bugzilla.gaia
Comment on attachment 769648 [details] [diff] [review]
patch for label and days overlap in Alarm list.[v1-train]

Review of attachment 769648 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for Leo's help on this issue. It works for me.
Could you please file a pr? Then, I can help you for merging it.
Attachment #769648 - Flags: review?(iliu) → review+
As per you review, I have opened a pull request.
Please review the patch at pointer to pull request at
https://github.com/mozilla-b2g/gaia/pull/10758
Attachment #770636 - Flags: review?(iliu)
Comment on attachment 770636 [details] [diff] [review]
Pointer to pull request

The same comment as comment3. Thanks.
Attachment #770636 - Flags: review?(iliu) → review+
Since the pr is landed, we can close the issue now.

master: 0b69872841d5df17df192968fa6d766c1f592864
Status: NEW → RESOLVED
Closed: 7 years ago
Keywords: regression
Resolution: --- → FIXED
v1-train: b12b6f8895427708fad4e25af180266085bd2e74
Duplicate of this bug: 894298
Since the issue is happened on v1.1.0hd, nominating hd+..
blocking-b2g: leo+ → hd?
if it's on leo+ it automatically gets merged to v1.1hd. resetting to leo+
blocking-b2g: hd? → leo+
Issue no longer reproduces on the Leo device.

Build ID: 20130716070204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/629020cf576b
Gaia: fb9362d34260771d4a00b9a0e10a6bbad397bd3b
Platform Version: 18.1

Was able to add multiple events in alarm. The alarm label and days of repeat no longer overlaps
Whiteboard: [LeoVB+]
v1.1.0hd: b12b6f8895427708fad4e25af180266085bd2e74
You need to log in before you can comment on or make changes to this bug.