[l10n] The content of the invite mail is in English

RESOLVED DUPLICATE of bug 956812

Status

RESOLVED DUPLICATE of bug 956812
5 years ago
4 years ago

People

(Reporter: flod, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Whiteboard: [Triage 2015-04-17])

(Reporter)

Description

5 years ago
This is the email message sent to someone invited

************

Subject: Diventa un Mozilliano

Hi there. Francesco Lodolo (xxxxx) has invited you to join mozillians.org, the community directory for Mozilla contributors. You can create a community profile for yourself and search for other contributors to learn more about them or get in touch.

Personal message:

Join Mozillians: https://mozillians.allizom.org/it/register/?code=xxxxx

Subject is correctly localized, but the content of the message is not.

************

Code: https://github.com/mozilla/mozillians/blob/master/apps/phonebook/templates/phonebook/invite_email.txt

It seems that these strings are marked as fuzzy in messages.po (line 1050)
http://viewvc.svn.mozilla.org/vc/projects/l10n-misc/trunk/mozillians/locales/en_US/LC_MESSAGES/messages.po?revision=117363&view=markup
(Reporter)

Comment 1

5 years ago
I can't really figure out how string extraction works, but could it be that it's just ignoring .txt files?

https://github.com/mozilla/funfactory/blob/master/funfactory/settings_base.py#L135

For example I see that Bedrock has that option changed in settings/base.py
https://github.com/mozilla/bedrock/blob/master/bedrock/settings/base.py#L556
(Reporter)

Comment 2

5 years ago
Still a valid bug.
Fixing this bug will raise another issue:

Since this is an invitation email and we don't know the language of the recipient, why should I prefer X language over Y when sending the invitation email?
(Reporter)

Comment 4

4 years ago
Good question. Maybe we should suggest the localized text and subject and let the user modify the invite if they want.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: [Triage 2015-04-17]
Duplicate of bug: 956812
You need to log in before you can comment on or make changes to this bug.