es.wikia.com/Wikia doesn't display correctly in Gaia browser

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: efrat, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [serversniff] [country-all] [sitewait], URL)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.116 Safari/537.36

Steps to reproduce:

Browsed to "http://es.wikia.com/Wikia" from Gaia browser

Tested on device: 
Model: ZTE Open
OS version: 1.0.1.0-prerelease
Firmware: V1.01.00.01.019.111
Platform:18.0
Build identifier:20130522003459


Actual results:

The site uploads as a desktop site and not mobile adjusted 


Expected results:

The web page should have been displayed correctly for mobile 
Displays correctly as a mobile site on Firefox for Android and Chrome for Android
(Reporter)

Comment 1

5 years ago
also when browsing to:
http://www.wikia.com
http://de.wikia.com/Wikia
Confirmed, appears to be sniffing on the server.

There is a contact page for bugs, http://api.wikia.com/wiki/Special:Contact/bug, but perhaps it would be more interesting to see if this module is included here and provide a patch: http://dev.wikia.com/wiki/Wikia_Developers_Wiki
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [serversniff][country-all][contactready]
(Assignee)

Comment 4

5 years ago
Mike,

indeed! 
https://github.com/Wikia/app/blob/dev/extensions/MobileFrontend/DeviceDetection.php#L287

Not sure how to solve this. The logic seems to be identification of well known devices/browser
then wap accept header
then if nothing else go to html.

Fixing that mean proposing to add identification for Firefox OS, which makes me a bit uncomfortable.


"Contacted" :) https://github.com/Wikia/app/pull/2045
Assignee: nobody → kdubost
Whiteboard: [serversniff][country-all][contactready] → [serversniff] [country-all] [sitewait]
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
This is fixed. Aka Firefox OS receives the mobile Web site. There are issues with some of the layout but It's tracked on Bug 804729
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
See Also: → bug 804729
You need to log in before you can comment on or make changes to this bug.