Uploading new version of application doesn't work.

VERIFIED FIXED in 2013-06-27

Status

Marketplace
Developer Pages
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: pawel.preczynski, Assigned: mat)

Tracking

({regression})

2013-06-27
regression
Points:
---

Details

(Whiteboard: [qa+])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/28.0.1500.52 Safari/537.36

Steps to reproduce:

My application status is "Status: Pending approval".

Try to upload new version of my application. I've clicked on choose file button, selected the desired zip file. 


Actual results:

File name changed. No errors in browser console. Nothing else happens. 


Expected results:

Progress bar should appear. File should be validated. Upload should be finished of error message should be shown.

Comment 1

5 years ago
This is reproducible in both stage and production. Please see screencast : http://screencast.com/t/n9RoLARN8
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

5 years ago
Bisected this down to this commit : https://github.com/mozilla/zamboni/commit/2a486af38a76eb671405463864c8bd11df0059fe
(Assignee)

Comment 3

5 years ago
FYI, This also breaks the validator. This is because both the validator and the app version page doesn't put their upload button inside a form with id="upload-webapp".
(Assignee)

Comment 4

5 years ago
Pull request: https://github.com/mozilla/zamboni/pull/853
Assignee: nobody → mpillard
Status: NEW → ASSIGNED
Target Milestone: --- → 2013-06-27
(Assignee)

Comment 5

5 years ago
PR landed, it's live on -dev.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Duplicate of this bug: 888346
Keywords: regression
Whiteboard: [qa+]

Comment 7

5 years ago
Able to upload newer versions now: https://marketplace-dev.allizom.org/developers/app/premium-packaged-app-1/status
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.