[SMS/MMS] When sending a message to an invalid number made up of alphabetic characters messaging app tries to send a message to a number

RESOLVED DUPLICATE of bug 920546

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED DUPLICATE of bug 920546
5 years ago
5 years ago

People

(Reporter: isabelrios, Unassigned)

Tracking

unspecified
x86_64
Windows 7

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: MMS_TEF [osloww])

(Reporter)

Description

5 years ago
Unagi device 06/28 build:
Gecko-db60841
Gaia-508cfc8

STR
1) ensure that a contact exists in the contact list with a valid mobile phone number.
2) open message app
3) select new message 
4) add a completely invalid number made of alphabetic characters to the 'to field': 'xxx'
5) type something in the message field
6) select send

ACTUAL
Three different behaviors seen depending on the network, SIM used:

6.1)
-Germany, O2 commercial sim:  If the invalid number in step 4) is made up of alphabetic characters such as 'ayman' the messages app attempts to send the message to '29626' which results in an error message being sent from my carrier telling that 'the speed dial 29626 is not assigned'

-Spain, movistar corporative sim card: If the invalid number in step 4) is made up of alphabetic characters such as 'ayman' the messages app attempts to send the message. A message from carrier (222000) is received: The dialed number is not a valid extension of the corporative service. Two threads are created, one with the name of the contact and the other with ‘ayman’.

-Spain, movistar commercial sim card: If the invalid number in step 4) is made up of alphabetic characters such as 'ayman' the messages app attempts to send the message. The message is not sent, it is possible to see the thread with the failure trying to send that message

6.2) 
-Germany, O2 commercial sim: If the invalid number in step 4) is made up of alphabetic characters such as 'YYY' the messages app attempts to send the message to '999' which results in an error message being sent from my carrier telling me that 'the speed dial 999 is not assigned'

-Spain, movistar corporative and commercial sims: If the invalid number in step 4) is made up of alphabetic characters such as 'YYY' the messages app attempts to send the message. The message is not sent, it is possible to see the thread with the failure trying to send that message.

EXPECTED
The app should try to send the message and give an error as it is unable to send it.
There should not be any kind of translation alphebetic characters into numbers like seems to be happening in 6.1 and 6.2.
(Reporter)

Updated

5 years ago
Blocks: 886764

Updated

5 years ago
Priority: -- → P1
Although this may be a bad user experience,keeping in mind this is not a regression, we are too late in the cycle to make an enhancement at this point in the 1.1 timeframe, hence switching to Koi ?
blocking-b2g: leo? → koi?

Updated

5 years ago
Target Milestone: --- → 1.1 QE4 (15jul)
not blocking by partners for leo.
This isn't a regression, nor is it incorrect: letters will always be converted to numbers. 

If I convert my personal number to letters "tkplg0wbmg"...

- From my personal phone, I can send a text to "tkplg0wbmg" and I will receive that text message 
- From my FFOS phone, I can send a text to "tkplg0wbmg" and I will receive that text message 

I recommend closing this as "WONTFIX" or "INVALID"

Updated

5 years ago
blocking-b2g: koi? → ---
Target Milestone: 1.1 QE4 (15jul) → ---
Maybe we could somehow show to the user that a conversion is happening/will be happening ?
Flags: needinfo?(aymanmaat)

Comment 5

5 years ago
(In reply to Julien Wajsberg [:julienw] from comment #4)
> Maybe we could somehow show to the user that a conversion is happening/will
> be happening ?

leaving ni? to me. We will discuss in Oslo.
Whiteboard: MMS_TEF → MMS_TEF [osloww]
blocking-b2g: --- → koi?
Not a blocker, please renominate if needed.
blocking-b2g: koi? → -
I filed bug 920546 to cover the most broken aspects of the recipient panel for 1.2.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 920546

Updated

5 years ago
Flags: needinfo?(aymanmaat)
You need to log in before you can comment on or make changes to this bug.