Issue with Abine's extensions (DoNotTrackMe, MaskMe) on Firefox 22

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: minijackson, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 769049 [details]
The MaskMe tab bug

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130620122336

Steps to reproduce:

I installed 2 Abine's addons : DoNotTrackMe and MaskMe on a previous version of Firefox on Linux. Everything worked well. Then, I upgraded Firefox to the 22's version.


Actual results:

DoNotTrackMe can't show me the trackers that are or not blocked (I think there is a 
problem with appending HTML code within the page) : when I click on the DnT button, the actual page seems to (re)load (loading icon on the tab) but nothing happens.

For the maskme extension, it's weirder : when I click on it, a new tab opens but nothing is in it (blank page). When I look at the source code, there is a head, with a title and plenty of scripts, but there is nothing in the body tag. I can't change the placement of the tab. I can't close the tab unless I go to a different URL. If change of tab without changing the URL (so leaving the blank page) I can't have the focus again on the MaskMe tab. If I want to have the focus on it, I must drag and drop the tab (but its placement still can't be changed). Now, if I changed the URL of the tab, I can change its placement, but it is sometimes buggy (the tab can be over an another tab). If the MaskMe tab is misplaced, it still can be closed (because the URL has been changed)


Expected results:

When I click on the DoNotTrackMe button, it should have shown the website trackers.
When I click on the MaskMe button, it should have opened a fully operational tab with the settings and the tab should not have been buggy.
(Reporter)

Updated

5 years ago
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 1

5 years ago
Created attachment 769052 [details]
Blank MaskMe page
This should be brought up to the developer's attention first. If it turns out to be a Firefox bug, please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.