Status

Firefox OS
Wifi
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: hub, Assigned: mwu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
I just rebuilt v1-train for my Keon GP-002(fx)

After flashing the phone couldn't find any wifi network.

it was working before with the vendor image.

gecko: 8a1953cec5ba17158bbd715c0647dc5189e4f472
gaia: c9e9b09cb181fcd15d12af09f89ff87f553c06c7
(Reporter)

Updated

5 years ago
Blocks: 855040
(Reporter)

Comment 1

5 years ago
I tried to make sure I had the right binary blobs by flashing 1.1 from GP first and then redoing the build (that would pull the files in backup-keon).

Still not working.

What is it that our build doesn't do that GPs is doing?
(In reply to Hubert Figuiere [:hub] from comment #1)
> I tried to make sure I had the right binary blobs by flashing 1.1 from GP
> first and then redoing the build (that would pull the files in backup-keon).
> 
> Still not working.
> 
> What is it that our build doesn't do that GPs is doing?

I build a v1-train branch for my Keon a couple days ago and wireless was working properly. Checked out B2G today fresh and did the same steps to build a new v1-train image and once installed, wireless is no longer working for me as you are reporting. So it seems something has changed in the last day or so in the v1-train code base or other repo.

dkl
OS: Linux → All
Hardware: x86_64 → All
adb logcat on bootup and initialization:

...
I/VolumeManager(  109): SetSharingMode for volume sdcard to 1 canBeShared = 1
I/AutoMounter(  109): UpdateState: umsAvail:1 umsEnabled:1 mode:0 usbCablePluggedIn:1 tryToShare:0
I/AutoMounter(  109): UpdateState: Volume sdcard is Mounted and inserted @ /mnt/sdcard gen 1 locked 0 sharing y
D/NetUtils(  109): ifc_set_addr ioctl
D/NetUtils(  109): ifc_set_addr(wlan0, xx) = -1
E/WifiHW  (  109): driver not loaded
W/AudioFlinger(  115): Thread AudioOut_1 cannot connect to the power manager service
I/GeckoDump(  109): exception: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsICrashReporter.annotateCrashReport]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrome://browser/content/shell.js :: <TOP_LEVEL> :: line 224"  data: no]
I/Gecko   (  109): ###################################### forms.js loaded
I/Gecko   (  109): ############################### browserElementPanning.js loaded
I/Gecko   (  109): ######################## BrowserElementChildPreload.js loaded
...

adb logcat when turning on Wifi in Settings:

...
I/IdleService(  108): SetTimerExpiryIfBefore: next timeout 1000 msec from now
I/IdleService(  108): reset timer expiry to 1010 msec from now
I/IdleService(  108): Reset idle timeout: tell observer 485500b0 user is back
D/NetUtils(  108): ifc_set_addr ioctl
E/WifiHW  (  108): driver not loaded
D/NetUtils(  108): ifc_set_addr(wlan0, xx) = -1
I/IdleService(  108): Get idle time: time since reset 864 msec
I/IdleService(  108): Idle timer callback: current idle time 864 msec
I/IdleService(  108): next timeout 135 msec from now
I/IdleService(  108): SetTimerExpiryIfBefore: next timeout 135 msec from now
...

Seems the driver is not present or crashing on initialization.

dkl
(Reporter)

Comment 4

5 years ago
(In reply to Hubert Figuiere [:hub] from comment #1)
> I tried to make sure I had the right binary blobs by flashing 1.1 from GP
> first and then redoing the build (that would pull the files in backup-keon).
> 
> Still not working.

For the record, these were from master nightly (gaia 2.0.0 and gecko 24a)

Trying a build of the master branch now.

Glad to see it was not only me.
Peaks seem to be busted for WiFi as well (profiling branch and m-c gecko in my case)
(Assignee)

Comment 6

5 years ago
Regression from bug 873018 . Taking.
Assignee: nobody → mwu
Depends on: 873018
(In reply to Michael Wu [:mwu] from comment #7)
> https://github.com/gp-b2g/external_compat-wireless/pull/2

I can confirm that this change fixes the wireless issue for me when rebuilding for Keon.

dkl
And peak
(Assignee)

Comment 10

5 years ago
Pull request merged.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

5 years ago
Works fine now. Thanks !
You need to log in before you can comment on or make changes to this bug.