If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Leo][Camera] Playing a video back after recording in landscape mode displays incorrectly

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Camera
VERIFIED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Sarah Parsons, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: leorun4)

Attachments

(1 attachment)

615.35 KB, text/plain
Details
(Reporter)

Description

4 years ago
Created attachment 769180 [details]
logcat

Description:
If the user records a video in landscape mode, the video does not play back properly when switching between landscape and portrait orientation. 

Repro Steps:
1) Updated to Leo Build ID: 20130625070217
2) Launch Camera App and select the video camera.
3) Put phone into landscape mode and begin recording. (20+ second video)
4) Play recorded video in Portrait and Landscape mode.

Actual:
Video plays incorrectly, appearing small and playing vertically instead of horizontally when trying to watch in landscape view.

Expected:
Video should play how it was originally recorded.

Environmental Variables
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/29933d1937db
Gaia: 1436e2778b90bd74635b0b94d1cf8ccb0d71b60c
Platform Version: 18.1
RIL Version: 01.01.00.019.138 

Notes:
Repro frequency: 100%
Test Suite Name: Camera
UCID: camera-005
Link to failed test case: https://moztrap.mozilla.org/results/case/223974/
See attached: Video clip http://youtu.be/1ZRGjjwLgaY

Comment 1

4 years ago
does not reproduce on Leo 7/15 build
 - video plays correctly in both landscape and portrait mode when launching from the thumbnail and also from Gallery and Video apps

Build ID: 20130715070218
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/6062fdf2deb8
Gaia: 55ed5e08a2250ea2d3571fff860c39e66fabed14
Platform Version: 18.1
RIL Version: 01.01.00.019.158 

resolving as Works For Me, please reopen if the issue reoccurs
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.