Closed Bug 888492 Opened 6 years ago Closed 6 years ago

Use the content window rather than tabbrowser for load notifications

Categories

(DevTools :: Inspector, defect)

x86
macOS
defect
Not set

Tracking

(firefox25 fixed, firefox26 fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: dcamp, Assigned: dcamp)

Details

(Whiteboard: [qa-])

Attachments

(1 file, 1 obsolete file)

Attached patch v1 (obsolete) — Splinter Review
Needed this for android to work.
Attachment #769182 - Flags: review?(jwalker)
Attachment #769182 - Flags: review?(jwalker) → review+
Comment on attachment 769182 [details] [diff] [review]
v1

This patch breaks things that it can't break.  Marking obsolete until I figure out why.
Attachment #769182 - Attachment is obsolete: true
Summary: Use the tab actor's _browser rather than _tabbrowser for load notifications → Use the content window rather than tabbrowser for load notifications
Attached patch webprogress.diffSplinter Review
This is much better.
Attachment #795500 - Flags: review?(jwalker)
Comment on attachment 795500 [details] [diff] [review]
webprogress.diff

Review of attachment 795500 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/devtools/server/actors/inspector.js
@@ +700,5 @@
>  var ProgressListener = Class({
>    extends: Unknown,
>    interfaces: ["nsIWebProgressListener", "nsISupportsWeakReference"],
>  
> +  initialize: function(tabActor) {

I'm trying to work out if this helps anything - we widen the scope of things we can break without apparent reason.
Attachment #795500 - Flags: review?(jwalker) → review+
https://hg.mozilla.org/integration/fx-team/rev/66674eef2042
Assignee: nobody → dcamp
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/66674eef2042
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
Comment on attachment 795500 [details] [diff] [review]
webprogress.diff

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Remote inspector
User impact if declined: This is related to bug 897194.
Testing completed (on m-c, etc.): been on m-c for a little while
Risk to taking this patch (and alternatives if risky): It affects devtools during navigation, but should be more help than harm.
String or IDL/UUID changes made by this patch: None.
Attachment #795500 - Flags: approval-mozilla-aurora?
Comment on attachment 795500 [details] [diff] [review]
webprogress.diff

Not worth tracking for release, but agreed on uplift.
Attachment #795500 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Assuming no verification needed here. Please add the verifyme keyword and remove the [qa-] whiteboard tag to request verification.
Whiteboard: [qa-]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.