Browser displays blank page when following URL from email

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: rituraj_tiwari, Assigned: karnaze)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1+) Gecko/20010626
BuildID:    2001062604

When I follow a new (not yet cached) URL from my email window, the browser
displays a blank page. In most cases doing view source on the page displays an
HTML document with text <html><body></body></html>. I *may* also have come
accross scenarios where I could see the correct page source but the browser
display was blank.
Hitting refresh brings up the page correctly.

-Tiwari

Reproducible: Always
Steps to Reproduce:
1.Open an email which has an uncached URL link in the message
2.Follow the link
3.Browser shows blank page
4.Hitting refresh brings up correct page
5. In some cases the displayed page will be blank even though view source would
show the correct source.

Comment 1

17 years ago
->layout
Assignee: asa → karnaze
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 2

17 years ago
Reporter, please try this with a newer build.

Comment 3

17 years ago
I can repro this on branch with current builds
Saw this all platforms on branch
win32 2001-07-11-06 0.9.2 branch
linux 2001-07-11-05 0.9.2 branch
mac 2001-07-11-13 0.9.2 branch
ALSO on Trunk 2001-07-06 build  win32

To Repro:
If I leave Mail app up, but close ALL open browser windows, then click on a link 
in a mail message, the blank page appears. After the first blank page, clicking 
on any links in mail will open the page correctly.

Maybe releated to bug 90393?
Nominating nsbeta1 for potential high visibility
Severity: normal → major
Keywords: nsbeta1

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All

Comment 4

17 years ago
cc lchiang

Comment 5

17 years ago
cc: vishy. I think this may be related (or even a duplicate) to a bug Vishy was 
telling PDT about where if there are no browser windows open, clicking a link in 
mail opens the browser window, but not to the URL clicked on.

I couldn't locate that bug number.
(Reporter)

Comment 6

17 years ago
Works for me on build 2001071104

-Tiwari
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 7

17 years ago
Lisa the bug number for the one you mentioned is 73141.  That was specific to
the first time the browser window is brought up by view message source or a link
in a mail message.  That bug was fixed and verified.  Suzanne's bug is different
because she tried her scenario on the 73141 fix and her bug was still there. 
Another bug like this (89691)is still opened and there are other bugs out there
that mention at random times clicking a link or view source presents a blank
page.   I don't think this one is fixed yet. 

Comment 8

17 years ago
Marking verified fixed in the Sept 5 build (2001-09-05-05).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.