Crash (X11 error) in nsHTMLEditor::HavePrivateHTMLFlavor with abort message: "X_DeleteProperty: BadAtom (invalid Atom parameter)" while copying&pasting on Linux

RESOLVED WORKSFORME

Status

()

Core
Editor
--
critical
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

({crash})

24 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment)

Got this crash:

https://crash-stats.mozilla.com/report/index/fa5c5641-3e3d-411d-a2bf-d082f2130629

I think I was editing an etherpad.

X_DeleteProperty: BadAtom (invalid Atom parameter); 2 requests agoxpcom_runtime_abort(###!!! ABORT: X_DeleteProperty: BadAtom (invalid Atom parameter); 2 requests ago: file /builds/slave/m-cen-l64-ntly-000000000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157)

Using a current Nightly. Linux x86-64.

Comment 1

5 years ago
(In reply to Benoit Jacob [:bjacob] from comment #0)
> Using a current Nightly. Linux x86-64.
24.0a1/20130621 is not the latest one.
Severity: normal → critical
Crash Signature: [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error ]
Keywords: crash
Summary: Crash (X11 error) with copy&paste on Linux → Crash (X11 error) in nsHTMLEditor::HavePrivateHTMLFlavor with abort message: "X_DeleteProperty: BadAtom (invalid Atom parameter)" while copying&pasting on Linux
(Reporter)

Comment 2

5 years ago
Indeed, updating to the latest Nightly seems to fix it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Updated

5 years ago
Duplicate of this bug: 892420

Updated

5 years ago
Status: RESOLVED → REOPENED
status-firefox24: --- → affected
Resolution: WORKSFORME → ---
Version: Trunk → 24 Branch
Just tried to paste the following content into an etherpad and Firefox crashed:

"the QA Release Driver will simply change the update channel to auroratest while updates are disabled on aurora"

It's reproducible for me.
Status: REOPENED → NEW
tracking-firefox24: --- → ?
status-firefox25: --- → affected
tracking-firefox25: --- → ?

Updated

5 years ago
Keywords: reproducible
Keywords: regressionwindow-wanted
It stopped reproducing for me. Steve, if its still crashing for you, it would be great if you could look for a regression range. Thanks!
Does it make a difference where the copied text comes from?
Is it copied from the same browser?  Same etherpad page?
In my case I have copied it from Thunderbird. So it was not the same application.
It crashed for me when copying from emacs, and when pasting from emacs to xclip, and then pasting what xclip produced. Let me try a few more variants, but I'd better submit this comment before I crash my browser again...
Ok, I just tried several things. So far, it seems to matter more where I'm pasting *to*, not where I'm copying from.

Pasting into a bugzilla comment:
 - copying from elsewhere in the page works
 - copying from standalone chatzilla works
 - copying from emacs fails to paste anything, but does not crash
 - copying from xclip works

Pasting into the first code region while editing https://developer.mozilla.org/en-US/docs/SpiderMonkey/JSAPI_User_Guide$edit :
 - copying from elsewhere in the same page crashes
 - copying from emacs crashes
 - copying from xclip crashes

I don't know about copying from chatzilla.
It's sporadic. I went back to that same MDN page and copied & pasted from the same page into a non-code region. It worked. Pasting into the 3rd code region worked. So did pasting into the second, and then even the first (which crashed in my other tests.) Copying from chatzilla into that 1st code region worked. Copying from emacs into that same code region then crashed.

I believe all of these are from these crashes:

bp-42242d41-37b2-48f4-a129-1d9d02130725	07/24/2013	05:07 PM
bp-80291e61-0829-458a-bad1-caa7c2130725	07/24/2013	05:02 PM
bp-3c479211-0ad9-49c1-829b-3f58d2130724	07/24/2013	10:19 AM
bp-f9767b81-1f6b-43ff-a895-268e32130724	07/24/2013	10:18 AM
bp-00d8e0e2-221b-4875-b1da-2fca82130724	07/24/2013	10:14 AM
bp-6544e8d0-8741-471b-ac1e-0d2cf2130724	07/24/2013	10:09 AM
bp-d41ac8e5-7e64-4194-99ef-5750d2130724	07/24/2013	10:08 AM
bp-4d74bbb4-5fd8-4021-ab37-ddf582130722	07/22/2013	11:33 AM
I made it crash again (xclip -> that 1st code region again) to capture the error output:

(firefox:1891): Gdk-CRITICAL **: IA__gdk_x11_atom_to_xatom_for_display: assertion `ATOM_TO_INDEX (atom) < virtual_atom_array->len' failed
###!!! ABORT: X_DeleteProperty: BadAtom (invalid Atom parameter); 2 requests ago: file /builds/slave/m-cen-l64-ntly-000000000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157
###!!! ABORT: X_DeleteProperty: BadAtom (invalid Atom parameter); 2 requests ago: file /builds/slave/m-cen-l64-ntly-000000000000000/build/toolkit/xre/nsX11ErrorHandler.cpp, line 157

Note that I entered that by pasting from a gnome-terminal, and it didn't crash. :-)
(In reply to Steve Fink [:sfink] from comment #12)
> (firefox:1891): Gdk-CRITICAL **: IA__gdk_x11_atom_to_xatom_for_display:
> assertion `ATOM_TO_INDEX (atom) < virtual_atom_array->len' failed

Are you able to set a break point in g_log and get a stack trace for this assertion, please?
G_DEBUG=fatal-criticals in the environment wouldn't require the break point.
Created attachment 780745 [details]
x11crash-withsyms.txt

Sorry, I can't seem to find debuginfo for libgdk-x11 (or gtk2, rather.)

Maybe I need to update the actual package first...
:sfink or anyone else, is this reproducible on Fx23 beta as well  or are we sure its FX24 regression ?
Adding QA as well to get help with information requested in comment# 16 or any more comments on the issue.
Keywords: qawanted
I've been unsuccessful reproducing a crash using the various methods mentioned in this bug. I've tried the latest Nightly, Aurora, Beta, and Release builds but none of them crash for me. Assuming you are still able to reproduce this can you please work on a regression window?
Flags: needinfo?(sphink)
Keywords: qawanted
Removing the reproducible keyword for now .Henrik/sfink please renominate if you are able to reproduce this.
tracking-firefox24: ? → ---
tracking-firefox25: ? → ---
Keywords: reproducible
Sorry, was on vacation. I tried Fx23 and was unable to reproduce. I will update my nightly (it's very old at this point) and check whether I can reproduce there.
Flags: needinfo?(sphink)
Not only can I not reproduce with the nightly 26.0a1 (2013-08-13), cutting & pasting actually *works*! It feels really weird -- it's been broken long enough to train me into expecting funky results. Now I'm happily cutting & pasting all over the place, something I don't normally do a lot of, just because it feels so nice to have it working again. :)

I'll needinfo? myself to confirm that I can still reproduce on 24, and check on 25.
Flags: needinfo?(sphink)
Perhaps this could be related to bug 907619, but you'd probably have to try pasting twice for that to cause this error.
Depends on: 907619
Henrik have you seen this bug recently? If not I nominate that we resolve this bug as WORKSFORME and reopen if it occurs again.
Flags: needinfo?(hskupin)
Keywords: regressionwindow-wanted
No, I haven't seen it again since the last time about 2 months ago.
Flags: needinfo?(hskupin)
Thanks Henrik, I'm resolving this WORKSFORME. Please reopen if this happens again.
Status: NEW → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox24: affected → ---
status-firefox25: affected → ---
Resolution: --- → WORKSFORME
I never did go back to recheck older version. I haven't had it happen on nightly at all, either.
Flags: needinfo?(sphink)
You need to log in before you can comment on or make changes to this bug.