[Gem Adventure] Bookmarking the game cause a slow down for the rest of the game.

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: nbp, Unassigned)

Tracking

({perf})

unspecified
1.3 C3/1.4 S3(31jan)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c= p= s=2014.01.31 u=])

(Reporter)

Description

5 years ago
Gem adventure game is found in everything.me panel, under game section.
The game can be played at a good pace on an Unagi, until we try to bookmark the game in which case the application becomes extremely slow and unplayable.

@21 show me the problem in the Paris office, and I was able to reproduce a similar slow down after trying to bookmark the application on mozilla-central build.

I have not yet tried with a b2g18 build.

Updated

5 years ago
Keywords: perf
Whiteboard: [c= p= u= s=]
Hi Nicolas, do you know if this is still an issue? Thanks!
Flags: needinfo?(nicolas.b.pierron)
Priority: -- → P4
(Reporter)

Comment 2

5 years ago
I cannot reproduce any speed difference between the bookmarked and the non-bookmarked application.

But we should probably evangelized about performance because the game is not really reactive either (on an Unagi), every touch takes easily ~100ms before anything start moving, and all animations are lagging.

Set as WORKFORME now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(nicolas.b.pierron)
Resolution: --- → WORKSFORME

Updated

5 years ago
Whiteboard: [c= p= u= s=] → [c= p= s=2014.01.31 u=]

Updated

5 years ago
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.