Last Comment Bug 88870 - Java support needed for carbon Mac OS X build
: Java support needed for carbon Mac OS X build
Status: VERIFIED FIXED
: meta
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: PowerPC Mac OS X
: P1 major with 60 votes (vote)
: ---
Assigned To: Patrick C. Beard
: Patty Mac
Mentors:
: 81458 91645 93707 109757 110130 115426 115509 120222 123577 126733 130259 130554 144142 (view as bug list)
Depends on: 81659 113499 113500 126578 127085 130740 132325 132564 135474 136063 148829
Blocks: 102989 102998 127253 148450
  Show dependency treegraph
 
Reported: 2001-07-02 12:57 PDT by Chris Petersen
Modified: 2005-05-26 10:49 PDT (History)
57 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch for building the MRJ plugin for Mac OS X. (1.04 KB, patch)
2001-12-20 11:42 PST, Patrick C. Beard
no flags Details | Diff | Splinter Review
crash log from trying to use java on .9.9+ and 1.b1 (13.44 KB, text/plain)
2002-03-13 14:26 PST, riscky
no flags Details

Description Chris Petersen 2001-07-02 12:57:54 PDT
Build: 2001061314
Platform: Mac OS X
Expected Results: Java support should be functional
What I got: Applets are not loaded. 
This report has been mentioned in
http://bugzilla.mozilla.org/show_bug.cgi?id=81659. However, that solution will
resolved this particular issue with our MRJ plug-in. To track this problem, I
have created a new bug report.

Steps to reproduce:

1) With MRJ Plugin installed, go to any page that contains applets.
Sample test
case:(http://mozilla.org/quality/browser/standards/html/applet_align_top.html)

2) Applets are not rendered.
Comment 1 Chris Petersen 2001-07-02 12:58:38 PDT
Changing Severity
Comment 2 Peter Lubczynski 2001-07-02 18:43:55 PDT
I think Patrick Beard is working on this.
Comment 3 Chris Petersen 2001-07-03 11:11:52 PDT
The following statement should have said:

"However, that solution will not resolved this particular issue with our MRJ
plug-in." in regards to bug 81659.


If this problem can't be resolved in the near future, I would see this problem
mentioned in the Read me for the OS X build.

 

Comment 4 Steve K 2001-07-03 16:28:22 PDT
Adding myself to the CC list.

I'm anxious to see this move forward;  With 0.9.2, this (and the resolved
plugins issue) seem to be the biggest impediments to mozilla being the best
browser on the platform.  (MSIE/MacOSX is still pretty flaky).
Comment 5 timeless 2001-07-03 18:50:10 PDT
*** Bug 81458 has been marked as a duplicate of this bug. ***
Comment 6 Adam Masri 2001-07-08 14:28:33 PDT
Set a dependency between this bug & bug 81659, since it is not fixed (I had to
reopen). This obviously won't be looked at until that one is complete.

- Adam
Comment 7 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2001-07-20 15:09:37 PDT
*** Bug 91645 has been marked as a duplicate of this bug. ***
Comment 8 Phil Schwartau 2001-08-05 23:53:03 PDT
*** Bug 93707 has been marked as a duplicate of this bug. ***
Comment 9 Patrick C. Beard 2001-08-22 14:02:07 PDT
I will start examining what it will take to write a new Java plugin for Mac OS X.
Comment 10 Tiantian Kong 2001-09-11 16:27:23 PDT
Changed milestone to future, as CPD currently does not have resources working 
on this feature.

Patrick: Are there any progress since we last talk about this bug?
Comment 11 Patrick C. Beard 2001-09-17 18:51:14 PDT
I have been making some progress on the implementation of an OJI plugin for Mac
OS X. I have been in contact with Apple engineers who have assisted me in
building a simple test application that successfully loads a Java applet.
Converting this to an OJI plugin isn't a huge leap.
Comment 12 Jaime Rodriguez, Jr. 2001-09-17 21:16:36 PDT
Nominating for PDT+ - -> Adding nsbranch+.
Comment 13 Hong Kwon 2001-09-18 17:32:49 PDT
nsenterprise-; not a stopper for enterprise
Comment 14 grega 2001-09-18 17:33:16 PDT
Can you give me a timeframe on when you'll have the plugin?  Need it asap if we
want this in 0.9.4.  
Comment 15 Patrick C. Beard 2001-09-18 18:55:56 PDT
This plugin will not be ready in time for 0.9.4, but that's probably OK, as it 
is a standalone piece of code.
Comment 16 Jaime Rodriguez, Jr. 2001-09-19 10:04:49 PDT
This is not on Tian Tian Must Fix list for this release. Should we consider
minusing it, and changing the priority for this release?
Comment 17 Jaime Rodriguez, Jr. 2001-09-19 10:10:25 PDT
This is not on Tian Tian Must Fix list for this release, and is targeted for
0.9.6. Should we consider minusing it, and changing the priority for this release?
Comment 18 Steve Dagley 2001-09-19 13:53:30 PDT
Not a stop ship
Comment 19 grega 2001-09-24 16:49:38 PDT
marking nsenterprise- to get off the enterprise stop ship list.
Comment 20 msanz 2001-09-26 08:44:05 PDT
adding PDT- as per all comments above
Comment 21 Jon Katz 2001-10-30 12:48:06 PST
There have been no updates in over a month. 
Comment 22 Giovanni Gatti 2001-10-30 12:53:05 PST
Yes, it a bit of a shame!

I bought OS X 10.1 hoping to get trading/push capacity via Java 2, but neither
Greatest Mozilla nor little Explorer 5.1.2 are able to do so.

:-(
Comment 23 Patrick C. Beard 2001-10-30 13:08:32 PST
I am currently working on some LiveConnect issues that have to do with the order
of ProxyJNI and SecurityManager creation.
Comment 24 Steve K 2001-11-05 09:03:51 PST
Patrick,

    We see all the sub-bugs you've been posting recently related to this, and it
looks like things are coming together; I was just wondering, are you developing
the OJI plugin for the CFM build, or the Mach-0 build (or will it be compatible
with either build)?

Thanks!
Comment 25 Patrick C. Beard 2001-11-05 12:19:21 PST
It's currently a CFM plugin. Our mach-O build will have to work with CFM
plugins, so this shouldn't be a problem.
Comment 26 Patrick C. Beard 2001-11-09 09:59:18 PST
The latest development version of the plugin is available here:

http://homepage.mac.com/pcbeard/MRJPluginCarbon-1.0d6.sit
Comment 27 Steve K 2001-11-09 10:35:38 PST
Glad to see it, Patrick!

I've gotten it and tried it out already, with our product which relies heavily
on Java Applets.  First thing I noticed is that, for one of our applets which
loads in a frame, it does _NOT_ suffer from the bug in MSIE where the applet
draws itself relative to a whole window, not it's proper frame.

Also noticed the following: a) One of our applets didn't completely initialize
(we'll look into this further), b) Occasionally, I've found our chat applet
wasn't accepting keyboard input, and then it would "flash", and start accepting
it, c) I've crashed a couple of times, but not sure if that's a Mozilla+Java
issue, or a Mozilla+QT issue.

I'll try to get an externally accessable and relatively unchanging external
testcase for these, and I'll attach the crashreporter log from the crashing I've
gotten here. 

Are you ready for any bugreports on this, or should we hold off for a little while?
Comment 28 Paul Carr 2001-11-12 19:38:51 PST
I've been using the plug-in, and it works well, rendering Applets accurately,
but now the browser refuses to quit normally whenver an applet has loaded in the
session.  This us under OS X 10.1.
Comment 29 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-09-26) 2001-11-13 02:35:57 PST
*** Bug 109757 has been marked as a duplicate of this bug. ***
Comment 30 Chris Brien 2001-11-14 03:54:02 PST
Very nice, but it doesn't seem to like having two codebases specified - eg one
for the .cab specified in the <object> tag, as well as the <param
name="codebase">. It then takes the .cab as the applet's codebase, where it use
use the <param>. Should I file a new bug for that?
Comment 31 Patrick C. Beard 2001-11-14 14:52:40 PST
*** Bug 110130 has been marked as a duplicate of this bug. ***
Comment 32 Patrick C. Beard 2001-11-15 13:20:54 PST
This is a meta tracking bug, so it has no target milestone.
Comment 33 nagano morey 2001-11-15 21:18:20 PST
Mozilla build ID 2001 11 15 06
Platform: MacOSX 10.0.4
version of the plugin is:
    http://homepage.mac.com/pcbeard/MRJPluginCarbon-1.0d6.sit


Menu:Help:About Plugins:
States that MRJPlugin is loaded & operational.
However, following the steps to reproduce error
still fails.

I still get the 'click here to get the plug-in message'
with all javaApplet pages I try.


Am I missing something?
Comment 34 Nick Zitzmann 2001-11-17 18:54:17 PST
Nagano, if I remember correctly, the plug-in requires Mac OS X 10.1 or later.
Comment 35 Giovanni Gatti 2001-11-18 01:39:43 PST
the plug-in I had to remove after upgrading to 10.1.1
Comment 36 Patrick C. Beard 2001-11-19 07:15:18 PST
Yes, the Mac OS X MRJ plugin uses APIs that are only available in Mac OS 
X version 10.1 and later. There is code in the plugin which checks, and 
explicitly refuses to load on earlier systems (otherwise it would crash).
Comment 37 nagano morey 2001-11-19 17:22:53 PST
The plug-in should be truthful and indicate that it doesn't work with 10.04.
    Plug-in Lies to User.


MenuBar:Help:About Plug-ins:
    Taunts the 10.04 user.
    Lists functions of the plug-in as enabled and ready.
    (in reality they're not even loaded, skipped over?)


Comment 38 Robert Brose 2001-11-23 10:10:50 PST
It works for me in mozilla 0.9.6 and macosx 10.1 on some java apps but try this
one as a test:

http://neo.jpl.nasa.gov/cgi-bin/db?200317

The framework of the applet shows up but the central area which contains the
orbits does not, it just appears blank white.
Comment 39 Anders Korsvall 2001-11-26 01:26:38 PST
Excellent work! I was very happy to see that even LiveConnect is being 
implemented. However, Java to JavaScript communication does not 
seem to work in 1.0d6. getWindow(Applet) always returns null. Is that 
work in progress?
Comment 40 fruit1 2001-11-28 11:10:37 PST
On OS X 10.1.1, Mozilla build 2001112020, Java plug-in 1.0d6, the mouse-over
applets on the following page do not work.  Instead, Mozilla indicates a new
plug-in is required so it's not recognizing the applets as being Java I guess.

http://www.pstnet.com/E-Prime/e-prime.htm

It will be a great relief to have Java on the Mac again!

Joe
Comment 41 Anders Korsvall 2001-12-04 14:03:15 PST
I found a couple of issues and filed bug 113499 and bug 113500.
Comment 42 Greg K. 2001-12-15 10:50:51 PST
*** Bug 115426 has been marked as a duplicate of this bug. ***
Comment 43 Greg K. 2001-12-16 15:55:28 PST
*** Bug 115509 has been marked as a duplicate of this bug. ***
Comment 44 abrody 2001-12-16 16:21:25 PST
The Java plugin http://homepage.mac.com/pcbeard/MRJPluginCarbon-
1.0d6.sit is very good...But what puzzles me, is I can enter Yahoo's http://
chat.yahoo.com chat rooms with it using Netscape 6.2.1 for Mac OS X, but 
not in Mozilla 0.9.6 latest nightly builds for X.   Other Java applets seem to 
work though in Mozilla 0.9.6 latest nightly build.   Might note though, this 
Java plugin does not work with any other browser for X than Mozilla and 
Netscape, and the Netscape 6.2.1 ability to view Java chat on Yahoo is 
limited to some extent because instead of just embedding the applet, it 
shrinks and then embeds the applet.   The shrinkage is about 1/4 off the 
size as appears normally in Classic browsers.  Thank you for making that 
plugin available.
Comment 45 abrody 2001-12-16 16:26:12 PST
I might add, I am using Mac OS X 10.1.1 5M28, 192MB of RAM, 
Powerbook G3/233 with 512k backside.
Comment 46 David Weber 2001-12-20 01:45:27 PST
Why is the MRJPluginCarbon not part of the daily builds for Mac OS X. It works
quite well and is definitely better than nothing. 
Comment 47 Patrick C. Beard 2001-12-20 11:23:38 PST
Unfortunately, the interfaces used to build it were hand crafted out of those
available in /System/Library/Frameworks/JavaEmbedding.framework. The changes to
build it are small, but nonetheless have to be made. I'll attach a diff to the
bug, and let's see what progress we can make in getting this automated.
Comment 48 Patrick C. Beard 2001-12-20 11:42:18 PST
Created attachment 62394 [details] [diff] [review]
Patch for building the MRJ plugin for Mac OS X.

This patch changes the files in
/System/Library/Frameworks/JavaEmbedding.framework/Headers so they can be used
with CodeWarrior Pro 7.
Comment 49 Nick Zitzmann 2002-01-15 17:09:49 PST
It's been a while since the last update. What's the status on this one?
Comment 50 Jaime Rodriguez, Jr. 2002-02-04 17:07:01 PST
agree with the last comment. dagley/beard, what are the chances this is gonna
make Mozilla 1.0?
Comment 51 Steve Dagley 2002-02-04 17:19:25 PST
It should make Moz 1.0 - bnesse and beard are actively working on the plugin.  We 
expect a new build to be posted later this week.  We want to get it into the 
Mozilla build RSN but we're talking to Apple about some headers we'll need before 
that can land.
Comment 52 Matthias Versen [:Matti] 2002-02-05 15:12:15 PST
*** Bug 123577 has been marked as a duplicate of this bug. ***
Comment 53 S. Rector 2002-02-05 18:13:08 PST
Plugin 1.0d7 no longer functions for Javascript on some URL's with the 0.9.8
build. Example:

http://www.wrh.noaa.gov/satellite/wr4kmiranim.html

The plugin worked with the 0.9.7 build for this URL and with similar Java UI
controlled animations.
Comment 54 Bruce Tomlin 2002-02-05 22:55:10 PST
I can't seem to get Yahoo Games to work with this.  Going to the game rooms
(such as http://games.yahoo.com/games/login?game=Go) and clicking on one of the
room links lets me bring up a game window, and the "Starting Plugin for type
application/x-java-vm" message appears in the status bar, but the game applet
does not load.  It works fine under IE.

This is with plugin version 1.0d6 and 1.0d7.
Comment 55 Matt Judy 2002-02-06 00:02:53 PST
Please also try PlaySite:

http://www.playsite.com/

PlaySite's games are very well done, and fairly complex Java.  PlaySite almost
works in IE.  There's a bug which prevents you from seeing the browser that lets
you join/watch a game.

It would be nice if Mozilla could do this while IE can not.
Comment 56 Ben Christensen 2002-02-12 22:18:33 PST
The plugin seems to work alright, however, the CPU usage is completely
ridiculous. Using a G4 550 with 512MB of RAM and OSX 10.1.2, it uses between 60%
and 75% of the cpu just displaying a page such as java.sun.com or any of the
games at games.yahoo.com. I could sort of understand a game of sorts, but not a
standard page with an applet on it such as java.sun.com. IE only takes 14 to 15%
which I still think is bad for a program just sitting stagnant and not being
used, but the improvement over previous Netscape 6 and Mozilla builds in getting
rid of idle CPU usage (which I'm very pleased by because I can actually use it
in the real world now) gets negated by this plugin on pages with applets.

Has this been seen on other systems, and I hope that efficiency will be
something looked at before releasing this, and hopefully in a build coming soon,
because I can't use a plugin that takes over 3/4's of my system just to display
some moving text.
Comment 57 Ben Christensen 2002-02-12 23:00:22 PST
In my previous post I talked about how Mozilla 0.9.8 uses over 70% of the CPU
showing java applets such as at java.sun.com. Interestingly, using Netscape 6.2
with the same plugin instead of Mozilla, the CPU usage is less than half for
Netscape than it is for Mozilla.

Anybody doing the builds understand why this is and what can be done to make
this better? and also consistent?
Comment 58 Patrick C. Beard 2002-02-13 19:05:51 PST
Under Mac OS X, we shouldn't have to give plugins nearly as much idle 
time as we currently do, because if they really need time to animate, etc. 
they can surely spin up their own threads.

This is especially true for the Java plugin. We should really consider 
implementing the feature where we ask the plugin the period at which it 
would like to receive idle messages. We could implement this feature 
using Carbon timers, and then stop using idle events altogether. The 
Java plugin would likely return a value indicating that it doesn't need any 
idle time.
Comment 59 Peter Lubczynski 2002-02-13 19:15:51 PST
Sounds like what NPPVpluginTimerInterval may be good for:
http://lxr.mozilla.org/mozilla/source/include/npapi.h#316

..but it doesn't look like it's implemented in the browser yet...
Comment 60 Bruce Davidson 2002-02-20 14:36:45 PST
*** Bug 126733 has been marked as a duplicate of this bug. ***
Comment 61 Jaime Rodriguez, Jr. 2002-02-21 14:56:53 PST
Since this is a META bug, we ought to "plus" the bug to make MRJ part of the OSX
builds.  Patrick, when you identify that bug, please plus it (nsbeta1+)!
Comment 62 Syd Logan 2002-02-22 20:35:54 PST
What is the estimated landing date for this? Could you please assign a
milestone, 0.9.9 or mozilla 1.0?
Comment 63 Steve Dagley 2002-02-22 20:40:11 PST
We're waiting on Apple to make some headers publicly available so the actual
build of the MRJPluginCarbon can be landed in the tree.  Work will continue from
that point.  As for when it'll be finished/declared a release build, the Moz 1.0
timeframe sounds about right.
Comment 64 Yuhui 2002-02-27 23:00:14 PST
I think the "acid test" should be using ICQ Lite. With Moz 0.9.8 (Build
2002020516) and MRJ Plug-In (Carbon) 1.0d7, I only get a gray window when I
click on the link at http://www.icqlite.com/. Since ICQ and Netscape are part of
AOL, I thought ICQ would work with Moz's MRJ Plug-in, but apparently not. I'm
running Moz on Mac OS X 10.1.3.
Comment 65 abrody 2002-02-28 06:21:34 PST
YMMV, but it seems for some people now with Mozilla 0.9.8 for Mac OS X they are 
having no trouble with the new plugin 1.0d8 
http://www.versiontracker.com/moreinfo.fcgi?id=13225&db=mac , and Apple's Java 
1.3.1 Update 1 Article 122000 when connecting to chat.yahoo.com.  Though I 
tried the same thing on an iMac G4 800 with yesterday's nightly build (2/27), 
and it wasn't able to load the chatroom in Yahoo.   It was able to load 
nbc4.com's calendar on the right side though which it has always been able to 
do.   When I tried it, the applet loaded on chat.yahoo.com, but no chatroom 
showed up.  And after about 3 minutes Mozilla unexpectedly quit in Mac OS X 
10.1.3.
Comment 66 Frankie 2002-02-28 06:57:43 PST
It seems like new releases (such as 1.0d8) should be mentioned here and/or bug
120222 instead of sending people to VersionTracker. Agree/disagree?
Comment 67 Bill McGonigle (not currently reading bugmail; please contact directly) 2002-02-28 07:16:20 PST
If it's popular enough to warrant attention on VersionTracker, it's probably
good enough to be part of the standard build, then people don't have to worry
about tracking it.  Sure, it's not perfect yet, but Mozilla isn't perfect yet,
so that's OK.  In my experience, the stability problems are gone, leaving only
compatibility problems, and applet users are used to that.

Dev. versions can continue to be mentioned on the newsgroup and hosted on
mac.com, where people who should be trying out every new version can find them.
Comment 68 Steve Dagley 2002-02-28 09:42:27 PST
Regarding the MRJCarbon plugin becoming part of the standard build - see my
earlier comment <http://bugzilla.mozilla.org/show_bug.cgi?id=88870#c63>
Comment 69 Jon Katz 2002-03-03 14:22:31 PST
Java applets served up via iPlanet/Netscape Proxy servers still don't work.
Using the latest MRJ Plugin (1.0d8) in both Netscape 6.2.1 and the latest
nightly build of Mozilla for OSX I get the same error. Care of Java Console Logging:

java.lang.ClassFormatError: NetMail (Bad magic number)
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(ClassLoader.java:486)
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:111)
	at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:142)
	at sun.plugin.security.PluginClassLoader.findClass(PluginClassLoader.java:213)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:297)
	at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:108)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:253)
	at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:373)
	at sun.applet.AppletPanel.createApplet(AppletPanel.java:598)
	at sun.applet.AppletPanel.runLoader(AppletPanel.java:534)
	at sun.applet.AppletPanel.run(AppletPanel.java:308)
	at java.lang.Thread.run(Thread.java:496)

The browser itself reports "Start: applet not initialized"

Other, simple Java pages (http://java.sun.com) seem to work without difficulty
on this system.
Comment 70 abrody 2002-03-03 20:02:03 PST
I got the lastest build and plugin and got an error while trying to chat on chat.yahoo.com on 
several instances.  The good news is that I finally managed to chat.  Here is my console log:
http://www.index-site.com/console.log
Comment 71 Brian Nesse (gone) 2002-03-04 08:58:46 PST
Jon, can you give a link that fails?

Abrody, you ran into the JS exception recursive death problem. I filed bug
127136 on this issue on 2/21 and the fix was landed over the weekend. I haven't
verified the final patch yet, but earlier versions fixed the problem.
Comment 72 Bruce Davidson 2002-03-12 10:30:59 PST
*** Bug 130259 has been marked as a duplicate of this bug. ***
Comment 73 Smith Kennedy 2002-03-12 15:01:02 PST
Added myself to the CC list.
Comment 74 abrody 2002-03-12 19:27:04 PST
Brian, the fix is yet to work on Build 2002031005.   Same problem.  I open
Mozilla, enter a Chat room on Yahoo, and browser quits and Console comes up.   

Date/Time:  2002-02-27 22:22:51 -0500
OS Version: 10.1.3 (Build 5Q45)
Host:       localhost

Command:    Mozilla
PID:        347

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0xbff82ff0 with lots after this.
Comment 75 Brian Nesse (gone) 2002-03-13 09:10:55 PST
I went to chat.yahoo.com using a 2002030608 Commercial build... worked
flawlessly for me. Are you having problems with any particular item, or just in
general?
Comment 76 abrody 2002-03-13 09:21:26 PST
Entering the chat room, the browser quits.   It tries to load the applet, and 
when the applet tries to render, the browser quits.  Running Mac OS X 10.1.3, 
MRJ Carbon Plugin 1.0d8.   If there is a newer version of the plugin, please 
let me know where I can download it?
Comment 77 abrody 2002-03-13 09:23:26 PST
Strange you say commercial build, I downloaded what appeared to be a commercial 
build as well.   0.9.9.  See my build number is even higher than yours.   Are 
we using the same OS?
Comment 78 Brian Nesse (gone) 2002-03-13 09:29:02 PST
Sorry, commercial == Netscape 6. latest plugin is at:
  http://homepage.mac.com/pcbeard/MRJPluginCarbon-1.0b1.sit
Comment 79 abrody 2002-03-13 09:45:45 PST
b1 is later than b8?   
Comment 80 Brian Nesse (gone) 2002-03-13 10:01:18 PST
Yes. b(eta)1 is newer than d(evelopment)8.
Comment 81 Frankie 2002-03-13 10:42:53 PST
I repeat: please Please PLEASE announce new versions of MRJ Plugin right here in
this bug. How was anyone supposed to know about 1.0b1? It's mentioned on neither
netscape.public.mozilla.macosx nor VersionTracker (which are also nice places to
announce, AFTER here).
Comment 82 abrody 2002-03-13 14:04:28 PST
OK, I got the new beta 1 build installed, before restarting I tried running the
same Mozilla build as above, and got http://www.macmaps.com/console.log error.
After restarting the Mac and trying the same chat applet over again I got an
error saying the applet did not initialize.   It seems plugins do not even begin
to work without a restart.   And even so, chat.yahoo.com chat applet which is
strangely supported on Netscape 6.2.1 for X is not under Mozilla 0.9.9. 
Somewhere along the lines some Java applets appear to be disabled by later
Mozilla builds.   
Comment 83 shrirang khanzode 2002-03-13 14:13:45 PST
i know this bug is abt osx...On win NT, with jre 1.3.1_02,I too cannot see the 
java chat applet working ( using nscp 621)
Comment 84 riscky 2002-03-13 14:26:39 PST
Created attachment 73973 [details]
crash log from trying to use java on .9.9+ and 1.b1

This is from my attempt to log into yahoo chat with the 1.b1 java plugin and
mozilla build 2002031308... just incase someone wants to look thru
Comment 85 Brian Nesse (gone) 2002-03-13 14:43:37 PST
abrody, do a Cmd-K on your log...it's getting tough to find the good stuff ;)

Riscky's attachment shows the current crash... this is almost certainly related
to bug 129250, the fix for which did not land on the 0.9.9 branch
Comment 86 Patty Mac 2002-03-13 14:58:42 PST
change to all platforms since the applets not loading on Mac os 9.2 as well 
(commercial netscape build:  2002-03-11-08-trunk).

1. Type this url:  http://chat.yahoo.com/
2. Make sure you log in your name and password (if you don't have one, you
   need to creat it, it's free).
3. Click on "Enter Chat Room"
Notice the applet is not loading.
Comment 87 Brian Nesse (gone) 2002-03-13 15:07:01 PST
No. Please open a specific bug for this. This is a META bug for the OSX MRJ
plugin. This will (does) work under OS X with the b2 plugin which we will post
as soon as we possibly can.
Comment 88 Chris Petersen 2002-03-13 21:26:58 PST
Nominating for topembed
Comment 89 Brian Nesse (gone) 2002-03-14 14:56:08 PST
b2 is available at the new and improved page:
  http://homepage.mac.com/pcbeard/MRJPlugin/

This should work better with Mozilla 0.9.9, but we have been seeing some issues
when used with Netscape 6.2.1.
Comment 90 Patrick C. Beard 2002-03-15 13:05:48 PST
Comment on attachment 73973 [details]
crash log from trying to use java on .9.9+ and 1.b1

This crash is caused by the fact of an incompatible interface change made to
nsIURI. This is why we had to respin v1.0b2.
Comment 91 Bruce Tomlin 2002-03-15 19:40:37 PST
Performance of 1.0b2 with http://goproblems.com/ is still ****. It works just
fine with the Windows Java plug-in under W2K.  But with the Carbon Java plug-in,
sometimes things don't draw, sometimes things don't draw until after the mouse
cursor is moved, and sometimes the wrong hit coordinates result from a mouse click.
Comment 92 Bruce Davidson 2002-03-16 03:56:56 PST
*** Bug 130554 has been marked as a duplicate of this bug. ***
Comment 93 Steve Dagley 2002-03-16 13:05:52 PST
*** Bug 120222 has been marked as a duplicate of this bug. ***
Comment 94 dan.m 2002-03-17 23:24:04 PST
After using the b2 plugin on .9.9 (OS 10.1.3) I noticed it was a little quicker
to load the java chat client (of the Digi-Chat variety), but there are still
three major weaknesses I noticed:

1. After a minute or two, typing into the text field becomes agonizingly slow.
As in, type 15 words, wait 45 seconds for it to fill in. Major text lag.

2. If you collapse a Window using WindowShade X, the contents of said window
will not fill in when you expand it again. You have to manually drag the resize
handle to get things to fill in properly.

3. You cannot launch a new Navigator window while a chat session is active (or
if you open a private chat window to talk to one person). The File menu just
stays highlighted after you let go of the mouse, but nothing happens.

All plugin files were installed directly into the internet plugins folder,
rather than using an alias.
Comment 95 Bruce Tomlin 2002-03-19 15:42:03 PST
In re my comment 91, updating to Java 1.3.1 Update 1 via Software Update has
completely fixed my trouble with http://goproblems.com/ .
Comment 96 Adam van Gaalen 2002-04-19 07:36:37 PDT
I just installed the new MRJPlugin but still cannot look at my aquarium-page at
URL http://www.macadam.dyndns.org/html/aquarium.html under MacOS X using
Netscape 6.2.2

All other browsers including a very old Netscape under MacOS 9 show this page
just fine.

Kind regards,
Adam@macadam.dyndns.org
Comment 97 abrody 2002-04-19 07:52:22 PDT
The question is, does that aquarium page load in the latest Mozilla build with 
the plugin.  Netscape builds are actually always older than Mozilla builds 
based on the same code as Mozilla.  If Mozilla can load the page and no major 
changes are made to Mozilla, then Netscape 6.2.3 should be able to load it when 
it comes out.
Comment 98 Per Olofsson 2002-04-19 08:20:22 PDT
The applet loads for me, with 0.9.9 and version 1.0b2 of the plugin.
Comment 99 abrody 2002-04-19 08:53:46 PDT
Looks like the plugin has reached final candidate 1 status:

http://homepage.mac.com/pcbeard/MRJPlugin/

Now we have another opportunity to see if the new plugin actually improves Mac 
OS X java loading in Mozilla and Netscape.
Comment 100 abrody 2002-04-19 08:55:28 PDT
Looks like the plugin has reached final candidate 1 status:

http://homepage.mac.com/pcbeard/MRJPlugin/

Now we have another opportunity to see if the new plugin actually improves Mac 
OS X java loading in Mozilla and Netscape.
Comment 101 abrody 2002-04-19 17:34:27 PDT
spinning beachball occurs now with 200204172 build of Mozilla for X and release candidate 1 
of the carbon Java plugin when visiting http://chat.yahoo.com/?room=
Macintosh::1600326592
after logging into my mail.yahoo.com mail account.  I can't login to http://chat.yahoo.com 
directly because now Mozilla doesn't render Javascript and stylesheets on that page like it 
did before this new build.   In any case, the applet loads, and I am stuck with a spinning 
beachball and forced to force quit the browser.   
Comment 102 edwin 2002-04-21 17:37:41 PDT
Is there a correlation between this bug and why the homepage.mac.com web page
list does not render properly. I'm on a Ti G400 running OS 10.1.4. When I login
to the "Homepage" start page, the list of web pages appears below the square
which the list should occupy. I am unable to select any of the pages on my web
page. I am also unable to select anything below the floating list of Homepage
pages. Are there any other iTools users who can duplicate this problem? Is this
related to WebObjects?
Comment 103 Steve Dagley 2002-04-21 18:55:38 PDT
edwin, no, this bug has nothing to do with the homepage.mac.com problem.  That
is a problem with the HTML/CSS being served by mac.com.  People should complain
to Apple that they need to make their pages compatible with Mozilla (I believe
the _supported_ browsers for mac.com are Netscape 4.x and IE 5.x).  There is an
evangelism bug logged for this I believe but the more people Apple hear it from
the more likely it will get fixed.  They have updated the slide show pages so
they work in Mozilla for example.
Comment 104 Chris Petersen 2002-04-22 11:20:09 PDT
Edwin,

This is the bug your are mentioning.

http://bugzilla.mozilla.org/show_bug.cgi?id=105791
Comment 105 Brian Nesse (gone) 2002-04-23 11:29:01 PDT
abrody, re: chat.yahoo.com, you might try a newer build. I got the same results
with a 20020419 branch build, but the builds around the weekend were pretty
flakey. Using a debug build from yesterday, I got into the chat rooms with no
problems.
Comment 106 saari (gone) 2002-04-23 12:56:13 PDT
removing topembed as this is a tracking bug
Comment 107 bassclar 2002-05-06 01:43:20 PDT
There is a typo in the install
doc for MRJPluginCarbon-1.0fc2

The path "/Library/Internet Plugins."
should be "/Library/Internet Plug-Ins",
or at least that's what it is on my
system. (Note the hyphen.)

It might also be a good idea to move the
period outside of the quotation marks,
but that's a clarity vs. correctness
issue I'll leave to others.
Comment 108 abrody 2002-05-06 05:54:41 PDT
Still doesn't consistantly fix the bug for http://chat.yahoo.com/  I thought a 
latest nightly build did that, but then installed the new plugin and once again
the chat client on Java doesn't work.   Anyone know who to contact at Yahoo to 
ensure their Java works with your plugin?
Comment 109 abrody 2002-05-06 05:57:42 PDT
I might add, I sometimes get a spinning beachball, sometimes am able to enter 
the Java chat just fine at http://chat.yahoo.com/  There is no consistancy.  
I'm always trying to enter the Macintosh:1 chat room.
Comment 110 abrody 2002-05-11 16:35:42 PDT
Still problematic with http://chat.yahoo.com and build 2002051005 and MRJ Carbon
plugin 1.0fc2.  Using Mac OS X 10.1.4 on a Flat Panel iMac.  Get the dreaded
spinning beachball, though I am able to force quit the program and reload it.
Comment 111 Boris Zbarsky [:bz] (TPAC) 2002-05-14 13:59:32 PDT
*** Bug 144142 has been marked as a duplicate of this bug. ***
Comment 112 Brian Nesse (gone) 2002-05-16 12:02:49 PDT
Current trunk builds have a plugin module originated regression caused by the
checkin for bug 120875. This is, unfortunately, causing major problems for the
MRJ plug-in right now. The branch builds (1.0.0rc builds) should not exhibit
these problems.
Comment 113 abrody 2002-05-19 19:40:10 PDT
Build 2002051908 still doesn't solve the bug with the 1.0fc2 plugin.   As a
matter of fact it only gets worse.  Now when I try to chat, Mozilla unexpectedly
crashes and generates this crash log:

http://www.macmaps.com/Mozillacrash.log
Comment 114 Brian Nesse (gone) 2002-05-20 09:06:38 PDT
According to the bug report, the fix wasn't checked in until last night... it
should be in this morning's build.
Comment 115 mark baseggio 2002-05-21 14:16:13 PDT
On the site www.dominategame.org (an online risk type game) Mozilla is actually
the only browser I can find for OSX that will play this game... at least to some
extent.

There is however a few problems, first of all processor utilization during
gameplay is absolutely insane... it sits at around 100% on average.  I'm
wondering if this is normal?  (I have an 800Mhz TiBook)

Secondly, and the more annoying problem is a constant and random
disconnect/reconnect problem.  It seems to randomly disconnect and reconnect to
the game, rendering a game finished.  Especially annoying after spending an hour
playing :)

On a warm note, good work with the plugin, and being the ONLY OSX browser that
works with this site!!

Mark
Comment 116 b4hand 2002-05-22 22:13:11 PDT
I don't know if this will help anyone, but I had a problem where the Java Plugin
wouldn't work.  It wasn't even showing up in About Plugins.  Finally, I tried
getting info on the plugin file, and the default association was with Netscape
4.x in OS 9 instead of Mozilla in OS X.  I changed the association to Mozilla
and the plugin started working.
Comment 117 Frankie 2002-05-31 13:10:37 PDT
Always the last to know... as mentioned on VersionTracker, MRJ Plugin Carbon 1.0
final is available now.
Comment 118 abrody 2002-05-31 18:53:44 PDT
The final plugin doesn't appear to be working on http://chat.yahoo.com/ yet with
Mozilla final candidate 3.   Obviously it isn't final yet.   
Comment 119 Steve Dagley 2002-05-31 19:00:47 PDT
The plugin is 1.0.  The Yahoo chat pages work for most (as well as for internal
testing).  Try bugging the folks at Yahoo.
Comment 120 abrody 2002-05-31 19:36:07 PDT
Steve, I've tried to find a place to contact a real person at Yahoo but it seems
impossible.  But perhaps coming from someone at Netscape maybe they'll listen.
Comment 121 Greg K. 2002-05-31 20:03:26 PDT
Yahoo Java chat WorksForMe using FizzillaCFM/2002052305 (RC3) and MRJ Plug-in 1.0.
Comment 122 Greg K. 2002-05-31 20:05:16 PDT
Please see my new bug 148471 about a problem between Java applets and tabbed
browsing (now blocking this bug).
Comment 124 riscky 2002-06-01 00:23:33 PDT
The links are not broken persay... apple has started to impose bandwidth control
on iDisk users... no one knows exactly how much bandwidth you get. However I
would think it would be a good idea to place the the plugin on the mozilla.org
site someplace...

BTW Kevin Gerich pinstripe theme had the same problem.
Comment 125 abrody 2002-06-02 05:04:12 PDT
Not only http://chat.yahoo.com/ but http://www.instantchess.com/ as well won't
work.  What happens in both instances with the latest release candidate 1.00rc3
of Mozilla for Mac OS X along with the MRJ Carbon plugin is that it gets stuck
trying to load the applet, leaving me with a spinning beachball.  It is possible
to force quit the browser, but that should not have to be done.  If a browser
finds an error in code, it should generate an error report.
Comment 126 Steve Dagley 2002-06-03 08:59:58 PDT
Keep in mind the browser simply uses the plugin to pass any Java applet to the
JVM built into Mac OS X.  No error checking of the code is possible.  When you
encounter the technicolor beachball of death with an applet use the Sampler app
to grab a log of what is happening in the Mozilla process (a 5 second sample
should be plenty).  Please log a seperate bug and attach the Sampler output if
you do that
Comment 127 m_mozilla 2002-06-03 09:17:19 PDT
> use the Sampler app


What is the sampler app? From where can it be obtained, and how is it used (or
where is its usage documented)?

-matt
Comment 128 Steve Dagley 2002-06-03 09:25:42 PDT
The Sampler app is part of the Mac OS X Developer Tools installation.  If the
tools installer isn't one of the CDs that came with your OS X package or
pre-installed on your Mac the tools image can be downloaded from the
developer.apple.com site.  There are some docs installed with the dev tools but
they're somewhat sparse when it comes to Sampler.  You might find more info
somewhere on the developer.apple.com website but personally I found Sampler
pretty clear w/o docs.
Comment 129 Brian Nesse (gone) 2002-06-03 11:08:24 PDT
WFM at chat.yahoo.com with RC3 and MRJ 1.0. I did reproduce the hang at
instantchess.com. Filed a general "MRJ hangs" bug (bug 148829) to cover this and
other "beachball" state bugs.
Comment 130 abrody 2002-06-19 17:43:12 PDT
Developers of the Java plugin may be interested in this webpage which Apple has
posted on their server: http://developer.apple.com/internet/java/enterprisejava.html

Hopefully this will help someone develop better Java support in Mozilla for Mac
OS X.
Comment 131 abrody 2002-06-19 17:44:16 PDT
Developers of the Java plugin may be interested in this webpage which Apple has
posted on their server: http://developer.apple.com/internet/java/enterprisejava.html

Hopefully this will help someone develop better Java support in Mozilla for Mac
OS X.
Comment 132 Patrick C. Beard 2002-06-24 11:13:16 PDT
This bug is all but finished. The remaining bugs are features we would like to have, but 
aren't critical.
Comment 133 abrody 2002-06-24 12:23:24 PDT
It is by no means finished...the start of this bug's issue hasn't been resolved 
by the latest browser or plugin.   This bug won't be finished until we Mac 
users can go to any Java site supported by any web browser and use Mozilla to 
view the same Java.
Comment 134 Mike Weaver 2002-06-25 08:18:57 PDT
Java is not working in most of the applications I try. For instance, the Compaq
Remote Insight Manager, Lights Out card's applets fail to initialize on the Mac
with the latest Moz stable and the final MRJ plugin.
Comment 135 Steve Dagley 2002-06-25 08:28:45 PDT
Do the applets that don't work in Mozilla with the 1.0 release plugin work in
any browser on OS X?  Keep in mind that some applets aren't going to work with
Apple's JVM and you'll need to evangelize the developer of the applet to fix them.
Comment 136 Anthony Papineau 2002-06-25 08:57:46 PDT
Lavalife java instant messenger works fine in IE 5.2 on OSX 10.1.5, however
Mozilla build 2002062503 with MRJ plugin 1.0 locks up with the spinning disk.
www.lavalife.com - (unfortunately, you need to be a memeber to get at the java
instant messenger- the guest login only gives a 'lookalike' frame that isn't
functional.)

Comment 137 Steve Dagley 2002-06-25 09:15:56 PDT
Please do not add comments about sites with applets not working to this bug. 
Please file a separate bug for each site.  This bug was logged as a meta bug to
track the issues that blocked the 1.0 release of the MRJCarbon plugin.  Now that
we've shipped that this bug is likely to be closed.
Comment 138 abrody 2002-06-25 09:22:59 PDT
I refuse to let this bug be closed until the bug is fixed.  It hasn't been 
fixed, the 1.0 plugin does not address the issue, we are waiting for a new 
plugin to address the issue.   I'll just reopen the bug if you close it.
Comment 139 abrody 2002-06-25 09:30:15 PDT
Please do not let this bug be closed until either Yahoo fixes their chat client 
to work with the release version of Mozilla for Mac OS X, or the Java plugin is 
able to understand Yahoo's chat in the release version of Mozilla for Mac OS 
X.  And while some pre 1.0 builds of Mozilla and Mac OS X appeared to have 
fixed the problem, the release builds of Mozilla for Mac OS X and the plugin 
have the issue reocurring.  Thank you.
Comment 140 Anthony Papineau 2002-06-25 09:39:25 PDT
Steve,  On 2002-06-25 you asked if any applets that didn't work in Mozilla
worked with any other browser.   My comments about Lavalife were not to
introduce new complaints, but to demonstrate that yes indeed, applets that don't
work in Mozilla do work in other browsers on OSX.
Comment 141 Chris P. Ross 2002-06-25 09:49:07 PDT
I'm sorry to spam this bug [s'more], but I completely agree with Steve in
comment #137 about what this bug refers to.  If you read the summary, this bug
tracks whether or not "support" is included for Java on Mac OS X.  It doesn't
say anywhere that the support should be flawless, or even "as functional as
other browsers".  While I agree that all of that is necessary; it is not
necessary for *this* bug.
Hopefully, if a single other bug is opened for tracking groups of java applets
that *don't* work with the MRJ 1.0 plugin, a reference can be logged here.
Comment 142 Steve Dagley 2002-06-25 10:00:06 PDT
Abrody, if this bug is closed and you re-open it your bugzilla access will be
'reconsidered'.  Have you filed a separate bug on the Yahoo problem as was asked
of you several months ago?  If you have it's not listed as a blocker for this
bug nor is it one of the 23 open bugzilla bugs with 'Yahoo' in the summary.  For
the last time I'll repeat that this bug was to get the version 1.0 of MRJCarbon
plugin out the door and that is done.

Anthony, telling us when a site works in other browsers but not Mozilla
definitely helps but they need to be logged as seperate bugs.  Closing this bug
doesn't mean we're not going to work on the MRJCarbon plugin, it just means the
1.0 version is done.
Comment 143 abrody 2002-06-25 10:18:02 PDT
No I haven't submitted a separate bug since I never received the request 
several months ago.   As you'll see in posts:

44, 65, 70, 74, 76, 82, 101, 125 support at first seemed to come back, only to 
later fizzle.  

And the fact remains the reason for my continued posting on this bug is that 
support in the Carbon build is not complete.   We need to work with Sun, 
Microsoft, and Yahoo to make sure their Java code is progressive and 
interchangeable, allowing people to use older versions of Java on their 
website.  It obviously isn't progressive as Netscape 4.7.9 and Explorer 5.0 for 
Mac OS 9 have no trouble with this applet when they have difficulty in Mac OS X 
which has a higher version of Sun's Java.  I would prefer it to be done in 
Mozilla since Mozilla has more standards support than any other web browser 
I've used to date in Mac OS X.  Java was supposed to be crossplatform from the 
beginning.  It looks like it never fullfilled that promise.  Keeping this bug 
open hopefully will open the doors to helping it do that.
Comment 144 Bill McGonigle (not currently reading bugmail; please contact directly) 2002-06-25 11:48:50 PDT
Oh, for heaven's sakes people, you can't have one bug that's used for every
problem java page any more than you can have one bug that's used for every
problem html page.  That's what the bugzilla database is for.  Maybe there
should be a java plug-in component, but that's another issue.

I filed a new bug for the yahoo chat problem, bug 154183 and set it to block bug
148829, the MRJ hangs bug.  I cc'd the folks with recent activity here; please
add or delete your cc: as per your interest.

As for this bug, Java Support for Fizilla was needed, and Java Support for
Fizilla was added. That's how I see it.  Thanks for the hard work, guys, I
really appreciate it.
Comment 145 abrody 2002-06-25 12:29:10 PDT
Thank you Bill...just so long as we aren't going to let development of the Java 
Carbon plugin stall at 1.0.   That's my concern, which hopefully is unfounded, 
and another reason why I want this bug to persist to help development of the 
next MRJ Carbon plugin.
Comment 146 Bill McGonigle (not currently reading bugmail; please contact directly) 2002-06-25 13:22:24 PDT
abrody, if Mozilla HTML rendering support stalled as soon as they got a basic
non-quirks parser going, your point would be well received.  But the Mozilla
guys go to great lengths to make everything work that can possibly work, so
there's no reason to fear that the MRJ plug-in will rot.  Bug 154183 has 0 votes
right now - incrementing that number would be a start to showing some community
interest in Yahoo! chat working on OSX.
Comment 147 riscky 2002-06-28 08:39:25 PDT
Maybe a meta bug should exist for Mac OS X MRJ plug-in issues... just an idea.
Comment 148 Patty Mac 2002-07-01 11:31:52 PDT
Chris Petersen and I also agreed this bug should verify and close it since the 
MRJ v1.0 is included in the package of the OSX daily build.
Comment 149 Patty Mac 2002-07-01 11:36:48 PDT
Verified on Mac OS 10.1.5 (branch build: 2002-06-27-05-1.0.0)

Note You need to log in before you can comment on or make changes to this bug.