Closed Bug 888775 Opened 6 years ago Closed 6 years ago

Lightweight themes causes tabs to shift down on Windows 7

Categories

(Firefox :: Theme, defect)

25 Branch
All
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 28

People

(Reporter: Aptget40, Assigned: Gijs)

References

Details

(Whiteboard: [Australis:M?][Australis:P1])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20130630 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130630040203

Steps to reproduce:

1) tried to apply a Persona
2) once Persona has been Applied cannot close tab or open another tab


Actual results:

what happens is when you apply the Persona the Tabs are all Crunched up, without a Persona, the Browser is fine, with Persona applied the Browser Tabz are all crunched up to the point i gotta re-add the Default  an close the Browser an re-open


Expected results:

Persona's should apply to the Browser without a Problem. i shall get a Screenshot of problem after i do this report.
Attachment #769524 - Flags: review+
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:M?]
Summary: Persona's Broken on UX → Persona causes tabs to shift down on Windows 7
Personas are now called Light Weight Themes (LWT), while Persona is the new name for BrowserID. Please clarify the Bug. Thanks!
if i have to do that just to satisfy your Ego well i will then stop posting Bug reports an Move over to Chrome, perhaps they'll actually fix Bugs  as you can see its a LIGHT WEIGHT THEME , PLEASE DELETE MY BUGZILLA ACCOUNT
This bug is likely to depend Bug 749804 
When applying this style all is well, but that is only a workaround

#addon-bar{
display: none !important;
}
Blocks: 749804
No longer blocks: australis-cust
Component: Untriaged → Theme
Hardware: x86_64 → All
Summary: Persona causes tabs to shift down on Windows 7 → Lightweight themes causes tabs to shift down on Windows 7
Whiteboard: [Australis:M?] → [Australis:M?][Australis:P1]
Version: 25 Branch → unspecified
Version: unspecified → 25 Branch
Attached patch PatchSplinter Review
So this was fun. It's because the drag bindings on Aero have some very specific selector, which re-enables the 'normal' toolbar bindings. Which import toolkit's toolbar.css. Which set min-height to 19px. Which makes the available space for the tabbar too small. And everyone was very sad.

Fortunately, just adding !important to the add-on bar binding is enough to fix this - and should also help make sure this doesn't happen anywhere else.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Attachment #770819 - Flags: review?(jaws)
Comment on attachment 770819 [details] [diff] [review]
Patch

Review of attachment 770819 [details] [diff] [review]:
-----------------------------------------------------------------

Why not just change:

>  #toolbar-menubar:not([autohide="true"]),
>  #TabsToolbar,
>  #navigator-toolbox > toolbar:not(#toolbar-menubar):-moz-lwtheme {
>    -moz-binding: url("chrome://browser/content/customizableui/toolbar.xml#toolbar-drag");
>  }

to

>  #toolbar-menubar:not([autohide="true"]),
>  #TabsToolbar,
>  #navigator-toolbox > toolbar:not(#toolbar-menubar):not(#addon-bar):-moz-lwtheme {
>    -moz-binding: url("chrome://browser/content/customizableui/toolbar.xml#toolbar-drag");
>  }
Attachment #770819 - Flags: review?(jaws)
Attached patch PatchSplinter Review
Attachment #771039 - Flags: review?(jaws)
Attachment #771039 - Flags: review?(jaws) → review+
https://hg.mozilla.org/projects/ux/rev/070ae719d242
Whiteboard: [Australis:M?][Australis:P1] → [Australis:M?][Australis:P1][fixed-in-ux]
This might have just re-broken bug 886281. Which makes no sense whatsoever.
https://tbpl.mozilla.org/?tree=UX&rev=070ae719d242

I've retriggered the orange to be sure. If it really did go orange, we probably need to back this out and figure out wth is going on.
https://hg.mozilla.org/mozilla-central/rev/070ae719d242
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:M?][Australis:P1][fixed-in-ux] → [Australis:M?][Australis:P1]
Target Milestone: --- → Firefox 28
You need to log in before you can comment on or make changes to this bug.