Inspect Network Request should show content sent to server with POST requests

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Console
--
enhancement
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: obrufau, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20130630 Firefox/25.0 (Nightly/Aurora)
Build ID: 20130630031138

Steps to reproduce:

Open the console and enter:

var xmlhttp = new XMLHttpRequest();
xmlhttp.open('POST','/myurl',true);
xmlhttp.send('hello world');

The console shows something like

x Post http://currentdomain.com/myurl [HTTP 1.1 404 NOT FOUND 672ms]

Click that line.


Actual results:

Inspect Network Request doesn't show the content sent to the server ('hello world')


Expected results:

Maybe it should be hidden be default (because it could be too long or non-readable), but I think that there should be an option to see sent content.
(Reporter)

Updated

5 years ago
Severity: normal → enhancement
Component: Untriaged → Developer Tools: Console
OS: Windows XP → All
Hardware: x86 → All
Version: 25 Branch → Trunk
(Reporter)

Updated

5 years ago
Version: Trunk → unspecified
Please check out the new Network Monitor panel in recent versions of Firefox (Aurora/Nightly). Hope you'll like it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
To reporter: in the web console you need to enable the 'log request and response bodies' option. Click the Network dropdown and you will find the option.
(Reporter)

Comment 3

5 years ago
Thanks, both Network Monitor panel and 'log request and response bodies' option work great!
You need to log in before you can comment on or make changes to this bug.