mixed font sizes when displaying chinese on japanese system

NEW
Assigned to

Status

()

Core
Internationalization
17 years ago
9 years ago

People

(Reporter: Yuying Long, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Reproduce on: 07-02 branch linux build
Not reproduce on: 06-08-06 trunk linux build

If you go to some traditional chinese page, e.g. 
http://www.sina.com.tw, http://www.china.com/zh_tw ... etc
you will see the font are not display in same size (see the attached image 
later).  

Is this because the check in of bug 87167? I didn't see this in 06-18-06 trunk 
build, and I can't verified it on after 06-18 trunk build because the bitmap 
scaled (bold looking) font problem.
(Reporter)

Comment 1

17 years ago
Created attachment 40934 [details]
Image of sina-tw
(Reporter)

Comment 2

17 years ago
Created attachment 40935 [details]
image of china.com tw
(Reporter)

Updated

17 years ago
Keywords: intl
QA Contact: andreasb → ylong

Comment 3

17 years ago
Reassign to bstell.
Assignee: nhotta → bstell
(Reporter)

Comment 4

17 years ago
I forgot to montion:
I don't have traditional chinese font in my Linux system, and even though, 
even though, on the build before 06-18 doesn't show this font bigger and smaller 
in same page. 

Comment 5

17 years ago
Yuying's test system is a Japanese system and does not have TW fonts so the font
subsystem is filling in from other fonts.

When we added so TW fonts to her system (temporary) then the page looked okay.

Can IQA determine what fonts a Chinese (simplified/traditional) system should have?

Without this information I do not believe it is possible to QA the fonts.

Marking future since we cannot QA this now.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Updated

17 years ago
Summary: The font size in traditional chinese page are not display constantly. → mixed font sizes when displaying chinese on japanese system

Comment 6

17 years ago
--> ftang
Assignee: bstell → ftang
Status: ASSIGNED → NEW

Comment 7

17 years ago
bulk move NEW FUTURE bug to ASSIGN
Status: NEW → ASSIGNED

Comment 8

14 years ago
what a hack. I have not touch mozilla code for 2 years. I didn't read these bugs
for 2 years. And they are still there. Just close them as won't fix to clean up.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX

Comment 9

14 years ago
Mass Reassign Please excuse the spam
Assignee: ftang → nobody

Comment 10

14 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 11

14 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: amyy → i18n
You need to log in before you can comment on or make changes to this bug.