The page description and better title are needed for the Firefox OS consumer page

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: kohei, Assigned: matej)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
The meta description (and OGP) is needed to help SEO and sharing.

I believe the title "Firefox OS — mozilla.org" can also be better.
(Assignee)

Comment 1

5 years ago
I think we're already planning on updating the title (Jen, can you confirm?).

Here's the new text:

Firefox OS — The Adaptive Phone — Great Smartphone Features, Apps & More — mozilla.org

Would that work for the meta description as well?
I'll let cmore speak to the OGP work, but yes, we'd like to update the title.

Thanks for the text, Matej.  I think that should work for the meta descriptino too.

Comment 3

5 years ago
I like Matej's description and as for the meta tags, Kohei's bug 834422 should address that too. Do it!
(Reporter)

Comment 4

5 years ago
A page description is shown in search engine result pages, along with the page title. It can be longer (150 characters) and different from the page title.

http://moz.com/learn/seo/meta-description
PR to update the page title here:

https://github.com/mozilla/bedrock/pull/1020
Not sure if making this text non localizable is a good idea.
(Reporter)

Comment 7

5 years ago
still waiting for the description (for SEO)
I'll wrap the string for localization and update

Do we have an appropriate meta description? Is there anything to be gained, SEO wise by just duplicating the page title?
Please wait for l10n, we ship stuff in non English speaking countries. Thanks
Created attachment 770140 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/1020

Pointer to Github pull-request
Kohei - please use the text Matej already provided for the description and the title.  Thank you.
I've updated the PR to include a meta description tag (reusing the page title copy).

Alex
Created attachment 772024 [details]
Pointer to Github pull request: https://github.com/mozilla/bedrock/pull/1020

Pointer to Github pull-request
(In reply to Pascal Chevrel:pascalc from comment #9)
> Please wait for l10n, we ship stuff in non English speaking countries. Thanks

All locales except Hungarian have translated these strings, feel free to push to production.
Thanks, Pascal.

Mike and Alex - let's get this one pushed this week.  Thx!

Comment 16

5 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/ad604df086668d690586c46d384d8bd6227ed8ad
Update Firefox OS page title bug 888861

https://github.com/mozilla/bedrock/commit/fb14f8fb0722fca0f58cd073e2f26db45ead597a
Merge pull request #1020 from alexgibson/update-page-title-firefox-os-bug-888861

Update Firefox OS page title bug 888861

Comment 17

5 years ago
Hey All, 

It looks like the copy part of this request is done. Is it ok to resolve this bug? 

Thanks!
Jennifer
fixed on stage https://www.allizom.org/en-US/firefox/os/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
No longer blocks: 888860
Duplicate of this bug: 888860
You need to log in before you can comment on or make changes to this bug.