'implied' url is listed as root when it should list current page

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
5 years ago

People

(Reporter: mozbugs, Assigned: clayton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
For example:

<a href='?var='> should result in http://www.mydom.com/page.htm?var=

Instead, it results in http://www.mydom.com/?var=
from RFC 2396:

  4.2. Same-document References
  
     A URI reference that does not contain a URI is a reference to the
     current document.  In other words, an empty URI reference within a
     document is interpreted as a reference to the start of that document,
     and a reference containing only a fragment identifier is a reference
     to the identified fragment of that document.  Traversal of such a
     reference should not result in an additional retrieval action.
     However, if the URI reference occurs in a context that is always
     intended to result in a new request, as in the case of HTML's FORM
     element, then an empty URI reference represents the base URI of the
     current document and should be replaced by that URI when transformed
     into a request.

Since a URI with a "?" is intended to cause a new request, this bug looks like
it's invalid.  I also seem to recall it being filed already.  ccing Bradley.
Whiteboard: DUPEME
Section C.1 of the same rfc (RFC 2396) also has:

C.1.  Normal Examples

 ?y            =  http://a/b/c/?y


for a document with a uri of "http://a/b/c/d;p?q"
Marking invalid based on above comments since nobody has pointed out the duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
SPAM. HTML Element component is deprecated, changing to Layout component. See
bug 88132 for details.
Come on Bugzilla, you can do it...
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.