Status

Air Mozilla
Venues
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: zandr, Unassigned)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

4 years ago
Camera 3 is unresponsive to control, has no video output, and shows an amber status light. Power cycling the camera had no effect.

Comment 1

4 years ago
Have you attempted a reboot of the system from the Crestron?
(Reporter)

Comment 2

4 years ago
Rebooting from the Crestron did solve the problem. We didn't realize that you were powering the cameras off and on.

So, what can we do to improve reliability here?

Comment 3

4 years ago
I spoke with Aaron today about this. I believe we will take one more pass at the HTML code from the Crestron to see if we can stabilize it, but I am less than confident this will be satisfactory. Option 2 we are researching is to control the cameras serial from the Crestron while leaving them HTML from the Panasonic controller. More research is reequired...

Comment 4

4 years ago
We've been discussing this and may have a solution if the issue is what we think it is.  It seems the TCP socket is being closed from the camera's side and the camera's protocol does not support "keep alive" over HTTP.  We are planning to write a script that queues commands until a connection is re-established.  Serial control needs to be investigated further, but at this point we think the cameras may behave the same with starting/stopping console connections, and we know an extra adapter from Panasonic is required, so we're hoping the queue scripting will be the answer.

Comment 5

4 years ago
This is sorted as of last night.  We had to employ some TCP socket trickery and create a command queue to force the socket open and closed around each command while respecting the required 130ms time between commands.  These cameras have an issue reliably accepting multiple commands during a single open socket session (the camera's default is to leave the socket open for 30 seconds after its last received command).

The results are good - the iPads no longer lock up and you can move the camera in very small increments just by tapping a ptz button.

Please test at your leisure and close this bug when satisfied.

Other items addressed:
 - Crestron PRO3 firmware updated;
 - Advanced audio page modified to include "Program Volume", "Video Call Volume" and "Audio Call Volume"
Seems to be working.  We'll reopen this bug if the problem recurrs.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.