Freezes for 1-2 seconds very often

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
2 years ago

People

(Reporter: Creak, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20100101 Firefox/22.0 Iceweasel/22.0 (Beta/Release)
Build ID: 20130626010340

Steps to reproduce:

Simply use Firefox intensively (around 20 pages loaded all the time for several months, with pinned pages too and a few plug-ins).
My configuration is set so that my session is kept each time I reopen Firefox.
Apparently it's not a problem from the plug-ins because I have the same bug when I deactivate all of them.


Actual results:

It freezes for 1 or 2 seconds apparently always when there is a new input (mouse scroll, text editing, changing tab). I look at the system monitor and one of my CPU is 100% exactly during the freeze period.


Expected results:

No freezes. Seamless browsing.
(Reporter)

Comment 1

5 years ago
Workaround:

Create a new profile.
(Reporter)

Comment 2

5 years ago
I also used the "tab groups" for some time and tried without but the bug was still there.
I suppose that the freezes are always present but are longer and longer with time.

Also, it seems to be the same as this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=549193
But this one was 3 years ago.

Comment 3

5 years ago
Does it depend on whether hardware acceleration is enabled (Preferences → Advanced → General)?

Do the "plug-ins" you've disabled include all extensions and themes?  Restarted Firefox after that?

Does it work in Safe mode?

Does the bug need any tabs to be open?
(Reporter)

Comment 4

5 years ago
Yes, the hardware acceleration is enabled.
I've disabled all the extensions (I don't use themes) and restarted Firefox after.

I haven't tried in safe mode.

The bug definitely needs tabs to be opened, not one specifically, the more the better apparently. I use the option so that the tabs that were opened on the last session are still here on the new session, so I often have more than 12 tabs opened at the same time.
(Reporter)

Comment 5

5 years ago
I've tested in safe mode and the bug is still here. It's like if the cache (or something else) get slowly corrupted by the time and, at some point, it begins to be sensible even on a quad core. I can't continue using my buggy profile for some obvious usability reasons, but I'm quite sure that the more I'll use it, the more it will get slow.

Comment 6

2 years ago
Are you still experience the issue on the latest Firefox versions?
 - Firefox 43: https://www.mozilla.org/en-US/firefox/new/
 - Nightly 46: https://nightly.mozilla.org/
Flags: needinfo?(romain.failliot)
(Reporter)

Comment 7

2 years ago
It makes quite some time I didn't have the problem again. Seems to have been fixed!
Thanks for the monitoring ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(romain.failliot)
Resolution: --- → INVALID
(Reporter)

Comment 8

2 years ago
I meant follow-up, not monitoring (bad translation ;))
You need to log in before you can comment on or make changes to this bug.